Can't print from center


#1

What is the problem? Printed from center until upgrade. to most recent Octoprint. Now it won't even though it is set to print from center in Octoprint and Cura 3.6...I haven't changed the onboard settings on the CTC Prusa i3.

What did you already try to solve it? I reset the print to center several times. It homes correctly then moves to the right then comes back and prints from home position...which is off the heat bed.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, Ioctoprint.log, serial.log or output on terminal tab, ...) I am new to 3d printing and I bought a cheap printer to "get started"...CTC i3 Prusa. It has printed very well for such a cheap machine until I upgraded the software....and also upgraded the machine I use to remotely control the printer to Linux Mint 19.1. At this moment I don't know the difference between Octoprint and Octopi...but I upgraded to the most recent version from within the dashboard of the interface on the Raspberry Pi model 3 B+ using the Mint machine to access. I set the print to center in both the Octopi/print configuration and also the Cura 3.6...but it still starts printing from home. I don't know what else to do and would appreciate assistance. Perhaps there is more information to be had on the forum but I have an eye disease and it is very hard for me to be at the computer for very long. Many Thanks. Oh...I am also not at the computer I use for control...however I can post any information that would help in a short while.


#2

Look in settings -> printer profiles, edit your printer, 'print bed' tab, 'origin' is probably set to "lower left". (also, hello from someone with two cornea transplants)


#3

Thanks...but it is set to print from center. I've double checked everything with no change. I just can't understand it...it has worked fine for months.


#4

That makes me asume there is a thinking error, can you show us your machine settings from Cura (Manage Printers -> [Your Printer] -> Machine Settings) as well as the setting from Octoprint (Settings -> Printer Profiles -> [Your Printer] -> Print Bed & Build Volume)


#5

Hi @Lynn_Reid! As @BerndJM tried to explain:
The origin (X/Y [0/0]) of a rectangular print area is for 99,99% the lower left.
Depending on the size of print area, the slicer calculates the data that way, that the object is printed onto the center of the print area, or where ever you moved it before slicing.
So do not mix up origin and center.