Can't reset the password to *Raspberry Pi itself* :(

Software: Octoprint 0.18.0. (the stable 0.17.0 doesn't work on my pi 4)
Raspberry Pi 4 Model B 2gb.

Inside Putty, I changed the password from "raspberry" to a new one as recommended by PRUSA.
And when I tried to log in with my new password, it says "Access denied".

I tried

I followed this guide to reset it (Googled: How to reset raspberry pi password).
Then this guide (Googled: octoprint reset ssh password).
I even tried to format & reinstall the Octopi image, I guess the password isn't stored there because it didn't work either.

Just can't reset it :frowning:
Thanks for the help in advance!

This is good practice.

Just to be clear: we're still talking about logging in via Putty, right?
Are you sure you are accessing the right IP address?
Is caps-lock or num-lock on?

After reinstalling the OctoPi image, the password for the pi user is set to "raspberry". There is no magical other place where a password is stored then on the system partition. So if "it didn't work either", something else is going on. You may be trying to log in on a different device in your network, or your keyboard is having issues.

Turns out that I typed "Pi" and it should be "pi" (username).
oof, I feel like an idiot.

Thank you!