Can't retrieve layer progress

What is the problem?
Every 5 mins or so I get an error that octodash can't communicate with the printer. However there seems to never be an issue as it never has failed a print (I stream them all) and octolapse works fine and it displays the layers etc fine aswell, mainly just a huge annoyance to touch the notification to dismiss it...can I just disable the notifications or something?

What did you already try to solve it?
Google but no-one really having this same issue.

Logs (syslog, dmesg, ... no logs, no support)
Not sure how to get any of them.

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)
I have a rpi 4 8gb running the latest octoprint 32bit stable using the latest octodash aswell (all plugins are latest)

did you install the DisplayLayerProgress plugin?

obviously or it wouldnt display it at all..I feel like you didn't read the issue in op?

You didn't say either way, there is no way for us to tell what's going on.

Click the words in blue, they are links - the octoprint.log would be most useful here.

octoprint.log (638.3 KB)

I deleted ^ and restarted everything and then redownloaded octoprint.log for a "fresh one" after the notification popped up again, I personally don't see any errors for it but also have no idea what I'm looking for so here is a fresh one after a delete (octoprint.log) > restart octoprint > waited for notification error > redownloaded octoprint_fresh.log (15.1 KB)

Agreed I can't see the errors there, probably just on OctoDash's side. I don't know if it logs anywhere that might be useful either. Someone OctoDash-savy will have to help on that one, or report the issue to the author on Github.

I've reported the issue on github aswell before here but no response there either, it's just an annoyance mainly it acts like it loses all connections for a split second then gets them all back almost instantly but like I said the annoying part is the notification pop up every 5 mins I have to manually dismiss.

I have the same issue but mine won't go away. I google it found a bunch of fix's on redit but none worked. I even redid my entire OctoPrint install and the error just stays on the screen. I cant even use mine as you click the screen and 2 sec the error message is back.

In, "Cyberbastler" gave a solution that worked for me:
nano ~/.config/octodash/config.json
Change "octopi.local" (or whatever your hostname is) to" localhost"