Can't see pi4 with octopi on network

What is the problem?

I have a headless Pi set up with an install of octoprint on a SD card that was working very well. I used the octopi image to burn it to the SD card.

I now cannot log into the octopi.local. I cannot see the pi on my network.


What did you already try to solve it?


I've checked my router and the pi is not on the network.

I have plugged a monitor in to the pi and booted it. I don't really understand the lines of code.

Have you tried running in safe mode?


I can't get that far

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


I can't get that far.

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


Sorry, I don't have that octopi version. I'm on macOS Catalina 10.15.7 and use safari.

I have attached a screen shot of the boot screen of the pi.

What is the next step?

I hope that helps. I'm not great with programming to be honest.

Thanks in advance


That link you see on the monitor,
Type that into your browser

1 Like

Thanks for the reply.
Yes, that would be the obvious thing to try and that indeed was the first thing I tried on my MacBook Pro. It didn't work. BUT, I think I have worked out the issue, but not the solution as of yet.
I pulled out my MacBook Air and tried that. Again no joy!
So I sent that message to this fine forum. Then about an hour later I tried to connect from my iPhone.
Boom! straight on! That was early hours of this morning....sleep was required.
I installed Adguard on both Macs, and also bought and installed Adguard VPN on the MBP. Its been no end of bother since I installed Adguard. my Mac keeps getting kicked off the network both email and browser servers. I have to quit the Adguard app and cycle wifi on and off. I think its related to that. I still can't access octoprint from my Mac...and I could do with it just now....quite a few prints to do.
I have quit both apps and removed them from start up. Still can't access octoprint.

Not sure what to do from here.

Further to my issue: I have managed to log in from a macOS install on a different partition on my MacBook Pro. Adgaurd is not installed on that MacOS build. So its something to with that very poor app. Although I have managed to log in to Octoprint and use it for prints, it states that octoprint has no connection to the internet. I did note the URL link on the menubar notification within Octoprint. Ive tried changing DNS servers and it makes no difference. I note that the gcodes I uploaded this evening all show as uploaded 4 months ago. This was the last time I managed to use Octoprint. I assume as Octoprint doesn't have a connection, it can't get clock info or indeed make updates. The Octoprint version is 1.7.0. I'll add a pic here with the server info that may help a wise one on here work out my issue. Thanks in advance!

I have finally solved my problem connecting to Octoprint on my Pi4 from macOS Catalina. I have two builds of MacOS on a MBP. One build (my main use build) stopped working or become erratic in connecting. A MacBook Air couldn't connect at all. An iPad Pro and iPhone 12 Pro Max connected without fault.

So on the MacOS that did work, I looked in networking and noticed that in Networking>Advanced>TCP/IP, IPv6 was set to "Automatic" in the drop down.

After switching to automatic on the other build and MacBook Air, I was able to connect with ease every time.

Thanks to those who reached out.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.