Can't see the drive after flashing

What is the problem?

I'm trying to install OctoPi V0.17.0 for my Raspberry Pi 4.

I flashed my 32GB microSD card using balenaEtcher. No problem. Now I'm supposed to edit a file on the root directory but I can't see the drive (SD card) any more on my computer. The drive showed up when I first plugged it in before I flashed it.

Flashing went easy with no issues. I just don't know how to edit a file when I can't even see the drive.

What did you already try to solve it?

I tried to re flash the drive but it sticks on "Starting" and doesn't flash again. Etcher can see the drive but my PC cannot.

I rebooted and I can now see the drive. On to next problem, I don't want to use wi-fi. I want to use a hard network connection.

No, you're supposed to edit a file on the first (/boot) partition. The second (/) partition is ext4 and cannot be read/mounted by either macOS or Windows.

If you don’t want to use wifi, then simply don’t configure it. Using ethernet should be as simple as plugging in the cable (provided there is a DHCP server on the network, which is normally on your router)

Sorry, my bad. I meant to say boot directory. Anyway, the problem was the SD card was not showing up. After rebooting Windoze, the SD card showed up and I was able to move forward.


No need to reboot windows. Etcher and all the imaging programs unmount the SD card after writing the image to it. Just remove the ad card when it's done, then plug it back in.


Thanks. I tried this several times but the SD card never showed up again in Windoze Explorer. It wasn't until I rebooted that Windoze Explorer could see the card.