Cant SSH into pi


#1

What is the problem?
Cant SSH into my pi

What did you already try to solve it?
Installed raspian, also octoprint(the actually reason for me doing it)

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)
Ive tried on a raspbery a+ a raspbery 2 and 3 re downloaded both images several times and reinstalled. Im plugged into ethernet.
i dont have a screen or keyboard to get in manually.

ive added a file ssh to the folder on the sd card.

I just get network error :Connection refused


#2

Hello @Woodys_Creations,

what program do you use to get into the Pi via SSH?


#3

Have you enabled ssh on the pi via raspi-config?


#4

Not OP, but I appreciate both @geoff_s and @Ewald_Ikemann you guys both led me to fixing my own issue using because I'm now using Putty instead of command prompt and enabling SSH. Not sure if the second was necessary, but I'm not going back. Thanks!


#5

I use putty to ssh into pi one of my pi's i can get into fine that one is currently running ont the tevo. but the other 3 i have i cant get in at all.

geoff_s i can get into the config as i dont have hdmi down in the dungeon where im working nor a keyboard.


#6

I must admit, it's been a while since I did an installation on a Pi. I know that it used to be that sshd was not enabled by default requiring a keyboard/monitor connection to get networking going.


#7

thats gonna be a pain int he backside lol i cant even get it on the web browser oh well guess they stay on the shelf for now :frowning:


#8

I assume, these other three Pis have other IP addresses than the one that works.
Or do you login via octopi.local?


#9

The existence of an empty /boot/ssh file will determine whether or not the Pi turns on that service. Having inserted the microSD card into my MacBook I might then do:

sudo touch /Volumes/boot/ssh

...then eject, put it back into the Raspberry and things would work out. That said, if you flash a newer OctoPi image you shouldn't have to worry about that; Guy has got you covered.