Can't ssh to change password

What is the problem?

Essentially the issue is I need to change the password. I cannot login to OctoPrint, even though I think I input correct password, but it won't let me in saying the username/pass is incorrect. It's a fresh 4 days install.
OctoPrint running on a raspberry pi zero w2. Ran fine for a few days, then had to restart the computer and re-login to Octorpint.

What did you already try to solve it?

I have looked up on possible ways to reset passwords and tried the following:

  1. ssh pi@192.168...etc, enter password: raspberry. Outcome: Permission denied, please try again.
  2. ssh pi@octopi.local enter password: raspberry. Outcome: same as 1
  3. Copy password from userconf.txt file on boot directory on sd card. Try number 1 and 2 - same outcome.
  4. Create a file named octopi-password.txt inside boot directory of sd card, containing single word raspberry, try number 1 and 2 - same outcome
  5. Create an empty file named ssh inside boot directory of sd card, try number 1 and 2 - same outcome. This also came with weird issues like timeouts when trying to ssh or unreachable octopi.local.
  6. Boot up OctoPrint and connect raspberry pi zero w2 to a monitor via hdmi. Outcome: no signal.

What else there is to try?

Hello @eight

Note, that depending on the use of the keyboard, some letters can be swapped.
On German keyboard vs English Y <> Z
On French vs English: A <> Q, W <> Z ...

Also tried copy/paste the passwords to be completely sure :slight_smile:

Since you say it is a 4 day old install, I would consider starting over. With the Raspberry Pi Imager you can set the initial username (suggest you stick with "pi") and password as well as WiFi credentials, SSH, and set your locale and location.

If you are not using (or can't use) the Raspberry Pi Imager, let us know the details of how you imaged the SD card and details on the host you are using for your SSH client.

Remember to shutdown the Raspberry Pi OS BEFORE cycling the power. Failure to do so may result in corrupting the SD card (which may be why you are having problems now).

Yeah, nothing else worked, so I just started over. Didn't lose much as it was a pretty fresh install anyway.
I have also made sure to select the ssh access check when installing. Tried ssh'ing after reinstall and it works fine now.