Can't update Octoprint to 1.7.X

What is the problem?

I have been trying to update Octoprint but it keeps failing. It tells me to look in the both the octoprint log and the plugin software update log to see why. When I do, I don't quite understand what is going wrong.
I have tried in both regular mode and safe mode.

The log has this line at the end
UpdateError: Error while executing pip install

I think these lines in the plugin software update log contains the error information but I don't know what it means.

2022-01-23 15:20:04,906 > Installing build dependencies: started
2022-01-23 15:20:04,908 > Installing build dependencies: finished with status 'error'
2022-01-23 15:20:04,910 > Complete output from command /home/pi/oprint/bin/python2 /home/pi/oprint/local/lib/python2.7/site-packages/pip install --ignore-installed --no-user --prefix /tmp/pip-build-env-mBPUo4/overlay --no-warn-script-location --no-binary :none: --only-binary :none: -i Simple index --extra-index-url piwheels - Simple index -- setuptools wheel Cython:

What did you already try to solve it?

See above

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/97.0.4692.71 Safari/537.36
connectivity.connection_ok: true
connectivity.enabled: true true
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1400
env.hardware.ram: 918188032
env.os.bits: 32 linux
env.os.platform: linux2
env.plugins.pi_support.model: Raspberry Pi 3 Model B Plus Rev 1.3
env.plugins.pi_support.octopi_version: 0.16.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 19.0.1
env.python.version: 2.7.13
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.6.0
systeminfo.generator: systemapi

Additional information about your setup

Version 1.6.0
Printer: custom build
Firmware: Marlin 2.X
Browser: Chrome
OS: Windows 11

plugin_softwareupdate_console update fails.log (354.8 KB)
octoprint update failed log.log (164.0 KB)

Please, just upload the actual systeminfo bundle (the zip file, not the text) or the full plugin_softwareupdate_console.log file, rather than copying the three lines you think are relevant.

Unrelated to this issue - you are running Python 2, which needs to be upgraded to Python 3:

Attached files

This issue

Where do I get the cleanup plugin? I don't see it in the repository

Hello @Heimlich_Mud !

What cleanup plugin?

@Heimlich_Mud did you open the post?

1 Like

User error. I was just seeing the search bar in for the repository, missed the outer scroll bar to get to the URL line. Fixed and updated. Thanks for the help!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.