Cant Update or install plugins-old version

What is the problem?

I have OctoPrint 1.3.12 running on OctoPi 0.16.0. As you can see i havent used the printer in a while and would like to update. However, when i try to do so, it always fails. This is also the case when updating plugins (telegram plugin for example).
I tried installing the filament manager plugin, it installed, but i cannot see it in the plugin list.

What did you already try to solve it?

Different power suply, disconnected everything, restarted.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

since i am in an older version, i cant download systeminfo bundle, but i will include the following
octoprint (1).log (194.2 KB)
plugin_softwareupdate_console.log (228.1 KB)

Additional information about your setup

Hello @TristanGB !

For you are running OctoPrint 1.3.12 on OctoPi 0.16.0 I would recommend to setup a whole new system.

You can backup your setup with the backup feature of OctoPrint and the new new installation fetches all plugins with the help of that backup file.

would all the configurations be copied as well?

Yes, it will be saved and restored

That's the meaning of a backup

I hate to rain on your parade but I don't think the backup feature of OctoPrint is going to do this across versions 1.3.12 to 1.6.? (the latest).

I'd start with a new SD card and a USB SD card reader/writer like or and then plug the old card into one of the RPi's USB ports, mount it, and copy the files you want to keep manually.

This USB SD card reader/writer can then be used later to backup the existing card on the RPi and other things.

It does older backups on newer versions, since it can upgrade the configuration - all the migrations stay in place. What it doesn't do is newer backups to older versions, since a new config scheme can be introduced that older versions don't understand.