Can't upload any files larger than several hundred KB

What is the problem?

I cannot upload any files larger than several hundred KB through Octoprint.

What did you already try to solve it?

I disabled WIFI and am using ethernet. I reimaged my SD card with a fresh install of Octoprint.

Have you tried running in safe mode?


Did running in safe mode solve the problem?

Systeminfo Bundle


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Using a Raspberry Pi 4 4GB with a 3.5A power supply from CanaKit. I am very new to raspberry pi and octoprint. Printing on a Prusa I3MK3S. Browser is Chrome.


I believe everything was working normally for the first day or two I had setup my Octopi. I was able to upload files, including I believe (but cannot remember 100%) several megabyte files. However, at some point when dragging over larger files (1-2 MB), they would hang up on loading, and then eventaully give me the error:

I have since done a new install of Octopi and have not had any success still. I can successfully upload 100-200 KB files. I have tried with files I have successfully printed from SD card. I have tried reslicing, renaming, still no luck.

I disabled WIFI on this install (or rather, did not update the supplicant file) as connecting to the web browser octoprint was very slow. Ethernet seems to be much faster, but still having issues with uploading files.

I wanted to update this for anyone else who may have an issue. While writing this, I decided to try something I have not tried before, and it goes as follows. Hopefully this can help someone with a similar issue:

I had been logging into the Octopi web browser by using the URL http://i3mk3s.local (this is what I had renamed it as).

It was taking forever to load, and I needed it to load so I could download logs for this post. So I remembered SSH shows IP address assigned to it. I SSH'd into it (had been waiting to load through http://i3mk3s.local for about 5 minutes at this point.

The SSH showed IP I plugged this into my browser and was instantly given a login screen. I logged in, and was connected. I tried a larger file (4 MB) and it uploaded quickly and flawlessly.

So I am not sure if there is a function difference between logging in to the web browser with the printer name vs. IP address, but it fixed it for me!!

By default, OctoPi relies on the DHCP server in the Local Area Network (LAN) to provide an IP address, netmask, gateway, DNS server(s), and a domain name. The DHCP server may also communicate with a local DNS server passing the hostname OctoPi sent as part of its DHCP request.

In many home networks, the DHCP server and the local DNS server are supplied by the router.
The .local domain name is often used by the Bonjour service which is an Apple invention.

Without knowing what router and what other systems are in your LAN, its hard to say why using the name is slow. You might try using http://i3mk3s (without the .local) and see if that works any better.

Thank you for this response. I will try that later tonight. I am running on Windows 10, and I was not aware .local was related to Apple. Now that I think about it, the guide I used to setup Octoprint was using Mac.

Not knowing any of what you mentioned, I was surprised that there was a difference between the name and the IP address. Figured this might be helpful for anyone in the future who may search with a similar issue.

I will update my results tonight.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.