Can't Upload Large (64Mb) GCode File to Octoprint

I am having trouble uploading a large .gcode file to Octoprint. It's a big print and 64Mb. I tried uploading via my plugin in Cura which does it for me, but after waiting for about 15 minutes, it stopped uploading and disappeared as if I didn't make an attempt to send to Octoprint.

I saved the .gcode file to my computer and tried uploading from the Octoprint server itself, and after about 10 minutes it was stuck at ~30%. I left my computer to do some other things, and when I came back an hour later, it errored out. I wish I had a screenshot but I was stupid enough to close the error notification.
The error stated a failure in uploading, and listed off the supported GCode extenstions (.gcode, .gco, etc.). I clicked for more info and that just yielded "undefined."

I couldn't find anything significant in my logs, searching for "undefined," "upload," "fail," or "error." Its just stuff for my plugins like The Spaghetti Detective, which shouldn't affect my uploading. (maybe?)

I'm running OctoPrint 1.3.11 on Octopi 0.15.1 on a Raspberry Pi 3 Model B+. Printer is Creality Ender 3 Pro, with TH3D Unified Firmware 1.2.10. The Pi is connected via ethernet if that matters.

Any help would be appreciated! Ultimately if I can't fix it, I can just use an SD Card but then I lose spaghetti detection and my ability to remotely cancel the print.

Could you try putting it into octoprint's uploads folder by copying it off a USB stick or putting the pi's SD card into a computer?

1 Like

Test if the issue persists in safe mode.

1 Like

This worked, thank you! I'm rebooting into normal mode and proceeding to print.

If you listed your installed plugins, it might help us in the future to track down which one caused the problem.

They're listed in the octoprint.log Pastebin link. I copied them here and separated the bundled plugins:


  • Action Command Prompt Support (bundled)
  • Announcement Plugin (bundled)
  • Anonymous Usage Tracking (bundled)
  • Application Keys Plugin (bundled)
  • Backup & Restore (bundled)
  • Core Wizard (bundled)
  • Discovery (bundled)
  • Error Tracking (bundled)
  • Force Login (bundled)
  • Logging (bundled)
  • Pi Support Plugin (bundled)
  • Plugin Manager (bundled)
  • Printer Safety Check (bundled)
  • Software Update (bundled)
  • Virtual Printer (bundled)

My Plugins

  • Bed Visualizer (0.1.8)
  • BetterHeaterTimeout (1.2.0)
  • Detailed Progress Plugin (0.1.4)
  • EEPROM Marlin Editor Plugin (1.2.1)
  • Emergency Stop Button (0.1.2)
  • Firmware Updater (1.4.0)
  • Octolapse (0.3.4)
  • PolarCloud (1.9)
  • The Spaghetti Detective (Beta) (0.7.0)
  • TP-Link Smartplug (0.9.16)

Hope this helps!

If it were me, I'd start toggling off some of the bundled plugins in order of likeliness that they'd include a hook into the files mechanism:

  1. Detailed Progress
  2. OctoLapse
  3. PolarCloud

In fact, I'd probably disable all three of these and then test. If it works after having done so, you can exonerate all the remaining plugins as being okay. And then systematically turn on PolarCloud, test, repeat until you find the culprit.

1 Like