Can't you swap the SD to another Pi and have it boot right up?

What is the problem?

I have a Pi 4b 2GB model Octopi/print has been running on for about a year now. I got my hands recently on an Pi 4b 8GB model. I figured swapping the SD card from one to the other would be the only thing I need to do. However, it never connects to WiFi as I never see it in the router's connected devices list nor does it respond to octopi.local address. Am I missing something?

What did you already try to solve it?

Swapped between power supplies, but that doesn't seem to be it. HDMI out has never worked (I don't think it has video out drivers), so I can't monitor anything on a screen.

Have you tried running in safe mode?

Don't know how based on the limited access I have

Did running in safe mode solve the problem?


Systeminfo Bundle (pulled from 2GB working Pi since I obviously can't access the 8GB Pi)

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/91.0.4472.124 Safari/537.36
connectivity.connection_ok: true
connectivity.enabled: true true
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1750
env.hardware.ram: 1979641856
env.os.bits: 32 linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 4 Model B Rev 1.1
env.plugins.pi_support.octopi_version: 0.17.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 20.2.3
env.python.version: 3.7.3
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.6.1
printer.firmware: Marlin Creality 3D
systeminfo.generator: systemapi

Additional information about your setup

OctoPi 0.17 doesn't support the Pi 4 8GB edition, so you'll either need to update it on the running Pi - using sudo apt update and sudo apt upgrade - or flash a new 0.18 image. The 8GB Pi was released after 0.17 was built.

It may be quicker to flash a newer image than to install the hundreds of package updates if you've never updated it before, but that's up to you.

Well, that explains a lot :slight_smile:
I'll have to try doing that. As soon as I figure how to get to the terminal since I've only ever accessed it (to my knowledge from octopi.local screen). I'll do the update to help preserve all my settings within octopi since I have a lot of customizations/plugins in there.

1 Like

All you need to do is on the existing Pi4 2gb, run sudo apt update sudo apt full-upgrade -y sudo rpi-update. Reboot and run sudo rpi-eeprom-update -d -a
That will update the kernel and the boot firmware code. Shut down the rpi4 2gb and put the card into the rpi4 8gb.

1 Like

Use putty.oad it on the PC and ssh to octopi.local
Login will be pi, password is raspberry if you've never changed that password. It's not the same as the one you use to access the web page

You can take a backup from within OctoPrint, flash a new image and then restore the backup, although that will only include OctoPrint stuff - any external scripts/software/configuration outside OP will be lost.

Ah! I am sure I have done that before. I'll do it from there. For a moment, I thought I was missing something (like there was supposed to be a visual linux interface/desktop with terminal I had access to, but could have sworn there wasn't one). I was right technically. I am also sure I have changed the pass and saved it in WinSCP at home. I'll try when I get back.

You are an awesome soul, my friend. Everything was processed successfully. I even installed speedtest-cli, and tweaked a few other things. Now running on the 8GB model. I plan to don't the 2GB model to someone in the fam looking to get their feet wet with this. A good day all around!