Change default web port on octopi 1.0.0

What is the problem?

How do I change the default port of 80 to a different port?
It appears HAPROXY is not used in Octopi 1.0.0 as those changes did nothing, and stopping HAPROXY didn't stop access to octoprint

What did you already try to solve it?

Changed port in HAPROXY and searched nginx config files. cannot find the port config

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (45.7 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octopi 1.0.0 Octoprint 1.8.6, Raspberry Pi 4B 8G, 128GB nvmE SSD

Haproxy is definitely used in OctoPi 1.0.0, the same way it has been in the previous versions. Can you share what changes you made to the haproxy config?

used the same changes I have in previous versions.

frontend public
        bind :8188
        #bind :::443 v4v6 ssl crt /etc/ssl/snakeoil.pem

I had to remove 2 of the colons and the v4v6 since ipv6 is disabled. same config I have used for the last year or more on previous versions. Also, shutting down haproxy still allows me to connect on port 80. Trying to connect on port 5000, which I used to be able to do if haproxy was down, no longer works at all.
Last octopi version was using Apache2, 1.0.0 is using nginx..

Ok. Decided to get back at it today. first attempted to connect as port 80 as I had been doing after install and after all my changes. i now get no connect... Try to connect as port 5000. nothing. try to connect as port 8188, it connects... Shut down haproxy... cannot connect as anything restart haproxy and it works as it should... I have no idea what may have happened after install, but it wasn't working properly at that time.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.