Change network of raspberry pi without connecting to raspberry pi?

What is the problem?
I was trying to connect to my 5G network and I went through:

raspi-config

and I went to manually put in the wifi name and did not put a password. It is very hard to access the raspberry pi, let alone setup an hdmi to connect. I then went to my router and made a guest network that had the same name but with no password. Octoprint connected and I am able to use octoprint, but I wish to change the wifi back to my original network at least. If possible connect it to my 5G network.

I can not connect via SSH, but I can through octoprint.

What did you already try to solve it?
I made a guest network that had the same name but with no password.

I tried to connect to the raspberry pi via IP through PuTTY but it says error: "network connection", from my original network. I tried to go to the guest wifi and connect but it did not work either. I am trying to look through octoprint to connect but I am not sure. Could I send something through gcode??? I have no idea.

Logs (syslog, dmesg, ... no logs, no support)

octoprint-logs (1).zip (434.8 KB)

  • List item

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)

I might be able to connect using USB, but I dont think raspberry pi will connect from USB to HDMI to monitor, right?

I am not super savvy, but could I connect to the raspberry pi via Octoprint Settings>Octroprint>Server?
or maybe through folder?

I hope I filled this post correctly, any and all help is much appreciated.

There's not really any good way to fix this if you can't at least SSH into the pi while connected to the guest network. The problem is probably the fact that it is a guest network, those usually have some form of isolation mode that doesn't allow communication between devices. I'm surprised you were even able to connect to OctoPrint if that was the case. If you can pull the SD card of the pi you could update it directly via octopi-wpa-supplicant.txt.

Aw dang! I was afraid of that. Say what if instead of a guest network I were to connect via a: IoT network? Are there any restrictions like with the guest networks?

by connect, I mean make a new network using the same name just switched what kind of network it was

Whatever that IoT network is supposed to be.

When you posted this questions there was a template in your edit window but you chose to delete / ignore it. You did the same thing with the other thread you opened a few hours ago.

Please generate a Systeminfo Bundle and upload it here. It makes no sense to keep us guessing when you hope to find help here.

Oh my goodness... My apologies once again! I seem to have clicked "Get Help - Network", wrote some stuff, and then I realized I was in the wrong section again and then switched over to just "Get Help" and I don't think it switched templates. And also before that friendly individual changed the section from network to general. I am still learning. My apologies for wasting everybody's time.

Anyways... The systeminfo bundle is:

octoprint-systeminfo-20211013220838.zip (126.8 KB)

To update, I did manage to connect via PuTTY by creating the IoT network under the same name (and turning off the guest wifi). That information from @jneilliii was very helpful. Thank you!

BUT... As I was editing the wpa_supplicant.conf. After rebooting, something seems to be not working because I am not able to find my device on my network, let alone connect to octopi.local/. After cutting a little whole to be able to get the micro sd card and I went to grab a ethernet cable to connect to PuTTY. I changed the wpa_supplicant.txt, I am now trying to change the wpa_supplicant.conf again but still is not working.

1 Like

Since you changed the wifi information on the pi with sudo raspi-config, you can no longer use the text file in the /boot partition. You now have to either use raspi-config, or use sudo nano /etc/wpa_supplicant/wpa_supplicant.conf
Raspi-config breaks the link to the /boot partition

1 Like

that's good to know. is that the same if one uses the raspberry pi imager to create the wifi connection details during flashing?

I fixed this disconnect at one point, are you sure it isn't working anymore?

Yep. Raspberry pi imager writes directly to the file in /etc/wpa_supplicant when you use it to inject wifi info

Raspberry Pi imager is verified to work - because there is a symlink between the two files, when it tries to write to /etc/wpa_supplicant.conf it is automatically redirected to the OctoPi WPA supplicant file. Not sure how the raspi-config tool works specifically, and if it is the same.

Remember that only the Raspberry Pi 4 can do 5 GHz WiFi.
Also remember that 5 GHz may be faster but has less range.
Make sure that your 2.4 GHz and 5 GHz networks have different names.

1 Like