Changed f/w, now Octoprint no bueno

What is the problem?

Probably inexperience :slight_smile: I installed Octoprint on my Ubuntu server ages ago to send files to my Sidewinder X1 with stock f/w. It worked fine. My bed was bowl shaped and I found this Youtube video about updating to Marlin in order to utilize mesh bed leveling.

That all worked just fine, but... now Octoprint will not connect. I can tell it tries. I hit "connect" and the motors all go silent and my display 'freezes' (sort of) temporarily. After 15 or so seconds of "connecting", the connection fails (no particular error that is obvious) and I have control of the display again, and Octoprint shows a "connect" button again. When I say "freeze", really all I mean is that I can't send commands (temperature, etc) from the LCD while Octoprint is trying to connect. After it fails, the commands I did send go through one at a time.

What did you already try to solve it?

I don't really know what to try, so not much. Currently I'm just no longer using Octoprint. Octoprint always "just worked" so I don't really know how to troubleshoot it.

Have you tried running in safe mode?

I have not. I Googled "how to start Octoprint in Safe Mode" and it says it is in the System menu. I've stared at the screen for 10 minutes and no System menu has managed to materialize. There is a tiny "System" down in the footer, but that leads to nothing regarding restarting. Come to think of it, I have no idea how to restart Octoprint, safe mode or otherwise.

Did running in safe mode solve the problem?


Systeminfo Bundle (5.5 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint version 1.7.3
Printer: Artillery Sidewinder X1
Firmware: Marlin
Browser: Chrome
O/S: Octoprint is running on Ubuntu 20.04. Browser is on Windows 11

Although... when fumbling through the menus attempting to find "restart in safe mode", I did come across:

Request exclusive access to the serial port
Uncheck this if you are having problems connecting to your printer.

That sounded promising. Unchecked that and now it appears I have control again via Octoprint. Any "gotchas" I should look out for?

Running Octoprint a OS which is not a RTOS is problematic. Why not get a Pi, it's just soo much easier for all sorts of reasons.

OctoPi isn't an RTOS either. Like Ubuntu Server, it is a Debian-based distribution.

Didn't know that. I stand corrected.

Easier how? What would be easier than using a server I already have that's a foot away from my printer? I imagine it was ported to rPi in the first place because it made it more accessible to people in terms of cost and portability/size... but if you've already got a $2k machine that's a trillion times as capable as a rPi sitting there...

I don't want to start a thing so I'll just agree with "I imagine it was ported to rPi in the first place because it made it more accessible to people in terms of cost and portability/size" and add that it seems to me that as most peeps run Octoprint on Pi's you are more likely to get community support.

Rule out that something else on your server is connected to the port, as that could explain issues locking it on connect (the freeze) and cause further issues down the road.

The problem with installing OctoPrint on a "a $2k machine that's a trillion times as capable as a rPi sitting there..." is disciplining yourself to NOT run anything else on this machine while it is printing.

As has been pointed out, neither solution uses a RTOS so the easiest way to approximate one is to limit the number of active tasks. I don't know about you but I'm much more likely to dedicate a $15-$50 Raspberry Pi to the task than a $2,000 server.

It won't be long before your 3D prints are multiple hours long with the occasional print time measured in days.

People here are... OSist? I get what you mean :slight_smile:

Good call. So far, so good. With that option unchecked, I can start a print from either the machine or Octoprint. I haven't tried making live adjustments on the printer with a file sent from Octo yet.

You seem to be of the impression that I'm new to this? I have multi-day prints all the time. I've never had an issue with Octopi not working so I'm not familiar with troubleshooting it (since it never had trouble).

I think you're wrong here. Again, I've never had trouble. I read about people having worse quality prints when running OctoPrint vs. direct from the machine and that has NEVER been my experience. I think OctoPrint is a pretty lightweight piece of software, and IF you're going to run into a problem, it is going to be with an under-powered device like an rPi. My machine is never, EVER going to bog down to the point it affects a print. My server backs-up files while I print. It runs as my home's fileserver while I print. It operates my home automation while I print. And it transcodes multiple streams of 4k video while I print. I've even run it to where those streams get to be too much and a TV show might have to buffer... while I print. There is zero need to be disciplined with what the server is doing in order to keep Octoprint happy... with one exception: I have to keep it on! I have twice (over the years) started a print and then decided to update my server and do a reboot, and... oops.

But otherwise, I can attest from years of experience, that a quality home media/file server can more than handle all its tasks and Octoprint and you never have to worry about that part of it.

Just to step in a little. Seeing this generally indicates (and I'm sure @b-morgan feels the same) that I need to make safe and reliable recommendations. You can definitely run on a beefy server, no problem. ...but there are basically two groups with custom installs. Users that do run a custom install but don't require support because they know what to look for on their own and those who simply blindly copy and paste commands from a guide. The latter needing those safe and reliable recommendations.

Glad you got it sorted though :slight_smile:


And we usually have no warning as to which of the two groups someone belongs until :poop: hits the fan, so we all err on the side of safe and reliable recommendations.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.