Changing default IP address

**Im trying to update to new octoprint, My ip address is defaulting to 169..... my network is 192.......


What did you already try to solve it?

Logs (syslog, dmesg, ... no logs, no support)

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)

That means it doesn't get an ip address assigned by your dhcp server.

Here is a quick guide on how to set a static ip on your ethernet interface

I plugged my pi into the ethernet and now its on my network and access through putty. Im trying to follow the guide you gave me, but when I enter /etc/dhcpcd.conf this is what its telling me

So you didn't get an IP on wifi?
Then you have to use an other interface in the config. It's wlan0 on my Pi 3+ but you can check it with ip link as the guide says.

you have to open the file with a text editor like nano
enter sudo nano /etc/dhcpcd.conf and exit it with ctrl + x

Are you sure that there isn't something wrong with your wifi connection? Did you check on your router if the pi is actually connected to it?
It's a bit weird if you get an IP assigned via ethernet but not via wifi.

The IP I was getting on wifi was the 169.xxxxxxx plugged into ethernet I get 192.xxxxxxxx
I changed the octopi wpa supplicant with notepad ++ All my network info was copied and pasted so I didnt miss spell anything. I had octopi on this before and didnt have this problem

WPA/WPA2 secured


Ok but what did your router say? Was it listed in the connected devices list?

only when it's connected to ethernet listed as octopi

Well that means your main problem is the wifi connection itself.
Please upload a picture of your octopi-wpa-supplicant.txt (blacken out the credentials).
Maybe there is a typo or formating error somewhere.

Everything seems to be ok

Next thing would be to check if the pi is able to detect the wifi.

Run sudo iwlist wlan0 scan | grep -i ssid in ssh and check if your wifi's ssid is listed.
Check also for spaces in the ssid string - we had cases where a space has been added to the ssid like in "test-wifi " for some reason.

Just checked and no spaces in my ssid

Sorry then I'm out of ideas right now.
Maybe somebody else has a suggestion for you.

If nobody comes up with something else we could try to configure the wifi again via ssh - but let's wait first.
Maybe I missed something.

Do you have any other wireless devices on the router? Are they working correctly? Routers can misbehave sometimes with wireless and DHCP. Can you reboot the router to see if that makes any difference?

The other option is to give the pi a fixed IP address but then you might have to make sure that it isn't in the routers DHCP address pool.

Is it line endings in the supplicant.txt file.

I see you are displaying it in notepad and it looks good, but if it is using Windows line ends \r\n instead of Unix/Linux line ends \n then it might look good in Notepad but be wrong so far as Linux is concerned. I believe the lates Notepad on WIndows 10 can support both so maybe worth checking what it is using.

Hey, No wifi is kicking my butt with a RPi 3B+, too. After spending too many hours trying different processes and methods from online, I've finally given up and bought a USB wifi adapter, and problem solved. What didn't work for me started with ethernet setup to fresh starts for OctoPi and RPiOS. Nothing worked. I've never had this type of issue with any of the other RPi models that I've ever used for home projects or work projects. I did find a ton of other RPi 3B+ with the same unresolved issue. Very disappointing. I can't imagine how frustrating this is for the school-aged kids. Ouch!

Alright, I gave up and bought a pi4 no problems connecting. I was using a tft50 touch screen (I should've mentioned in the beginning) and after doing some research, I found out the screen was blocking or "jamming" the wifi signal for the pi3b+. This was definitely a headache lol. Thanks, for the help.

Adding to this thread to report something weird with the TFT50 screen and a 3b+ Wifi connection.

  • the 3b+ is not able to get Wifi address when the TFT500 screen is right next to it -> looks like interference, got it!
  • Just changing the memory card and booting the Raspberry Pi OS and the Wifi is working OK - no change in hardware or distance between the TFT50 screen and the 3b+ -> why is this working with some strong good signal now?? Shouldn't the screen interference be the same regardless of the OS being used? Are the Wifi drivers different between Octopi and the Pi OS???

OctoPi is Raspberry Pi OS (Lite) with OctoPrint & a few other bits pre-installed, so it is interesting that one works and the other doesn't...

has anyone successfully created a static IP on wlan recently? I have 3 octopi servers with this setup, but I've tried on a pi3b and a new pi4 by editing the dhcpcd.conf file, and once I apply a static I lose ability to ssh to the pi.

wifi works fine with dhcp, but I want to bring the camera feeds into home assistant, so that wont work.

did the way octopi handles static addresses change?