Changing Hostname

What is the problem?

Have tried several methods to change Hostname. Have a Pi on two different printers.

What did you already try to solve it?

Have tried Raspberry Pi Imager advanced options. Have also tried creating octopi-hostname.txt both without success. The octopi-hostname.txt method the OS seems to want to load (I am on a MacBook) and the horizontal progress line under URL runs across, but never asks for Log In. Have also tried putting a blank SSH file in Boot SD and Terminal says Unknown Command when I send

  • run sudo raspi-config

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPi_0.18.0-1.7.3, AnyCubic Vyper 2.3.9, Safari 15.3, MacOS 12.2.1

here is System Info Bundle

can you ssh into the pi?
If so, you can change the hostname like this:

sudo su
echo "newhostname" > /etc/hostname

Or place a file octopi-hostname.txt containing the new hostname in /boot or the SD card's root when using it as a thumb drive in e.g. Windows.

dont type "run" only type:
sudo raspi-config
then hit enter

  1. Cannot SSH in PI with or without the SSH empty file.
  2. Not typing run before the sudo command.
  3. Created octopi-hostname.txt for both Creality and Vyper Pi's and neither works.

I am beginning to wonder if macOS Monterey 12.2.1 has an issue with Raspberry Pi SSH. Have also tried to use Apple Terminal without success. When asked for password nothing is typed in so command is refused. Getting same results in Ezpi is reason I am pointing at MacOS. Realize you don't have control of MacOS.

This is intentional for Linux devices, when you receive the password prompt, type the password and press enter. You won't see it being typed but it should work.

Thanks for tip, but have tried Pressing Enter after typing in Password and no joy.

Do you use an English layout keyboard or another localisation?

English keyboard

Do you get any prompt on the screen?

Not sure what you are asking. After typing in password and hitting Enter it went back to asking for password. Did that 3 times and then if I remember correctly it kicked me out.

The username was filled in by putty?

Ewald, sorry I am not comfortable with Putty or Pronterface. Just old guy having fun with 3D printing.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.