Changing the port - unable to access webUI

What is the problem?

Hello - I changed the port from 80 to 5001 so that I could use pihole on the same raspberry. However I am now no longer able to access the webui. Is there anything I'm missing or did wrong?

What I did was changed /etc/haproxy/haproxy.cfg to

frontend public
bind :::5001 v4v6
bind :::443 v4v6 ssl crt /etc/ssl/snakeoil.pem
option forwardfor except
use_backend webcam if { path_beg /webcam/ }
default_backend octoprint

What did you already try to solve it?

tried to change to other ports to no luck

Have you tried running in safe mode and if so did it solve the issue?


After making the change to the haproxy.cfg file and restarting haproxy (sudo service haproxy restart) then you would need to access the octoprint interface at http://ipaddress:5001/ or via https://ipaddress/, but without seeing your logs it's hard to tell if the connection is even making it to OctoPrint. What is the error you are receiving?

Also, running pi hole and OctoPrint on the same Pi is really not recommended. Depending on how active your network is, pi hole can be quite resource hungry and tie down the Pi so much that it will no longer be able to reliably feed your printer.

1 Like