Changing Web Cam Listening Port

Camera model


What is the problem?

I looked at the NetStat of the camera port 8080 and it looks like its only listening to

What did you already try to solve it?

Looked up online to find the config file that is setting, with no avail.

How do i change the port to listen on I am trying to get RTMP working and my docker container cannot see the camera without setting it listen to any address.

Thank You

In case any one else has the same issue. Go to /boot/webcam-streamer/usb-default.conf under the options= put this after the equals '--http-listen=""' once done so reboot and the camera will listen to any ip and docker container will be able to stream.

1 Like

The underlying reason for this is that the webcam is proxied to be available on /webcam/, so that both OctoPrint (technically running on port 5000) and camera-streamer (running on port 8080) are both available on port 80, so you don't need to specify it. As the webcam is proxied to /webcam/ it is generally available through 8080 by default.