Changing wifi password on octopi changing octopi-wpa-supplicant.txt

What is the problem?
Each time I change my wifi SSID and password within the octopi-wpa-supplicant.txt, unmounting the SD card from my PC and than remounting it will result in the original settings be put back in the file. So no matter what I do the settings will always revert back to the old settings. I've also tried to copy the file and edit it from my local machine and then putting it on the SD card, but this will result in the file only showing ������....���� this weird question mark icon.

What did you already try to solve it?

  • Changing SD card readers. I've tried two
  • Changing code editor. I tried Atom, VS code and Text edit

Logs (octoprint.log, serial.log or output on terminal tab, browser error console ...)

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ...)

  • OctoPrint Version 1.3.11
  • OctoPi Version 0.15.1

Putting the wifi info in that file ONLY works on the first boot.
in order to change it after the initial boot, you either need a keyboard and mouse on the pi and do "sudo nano /etc/wpa_supplicant/wpa_supplicant.conf" and change it, save and exit
Or, put the SD card in another linux machine, and go to the /etc/wpa_supplicant folder on the SD card and edit wpa_supplicant.conf

You need to do the software eject in your workstation's operating system to flush any outstanding write commands to that device. It sounds like you're just pulling it out of the slot.

As long as the update_config=1 line is in that file it will update the underlying /etc/wpa_supplicant.conf in the Raspbian configuration every boot, for what it's worth.