Checksum, Line number problem


#1

What is the problem?
The print does not start:

For some days now I keep on getting these messages in Terminal:

Send: N12 G0 F3600 X80.178 Y106.471 Z0.3*28
Recv: Serial Error: Line Number is not Last Line Number+1, Last Line:9
Recv: Resend:10
Recv: ok

I already did some restarts, for Octoprint, for the machine, made new files, etc.

In between nothing changed, or it must be an upgrade to Octoprint 1.3.8.

I don't have info about my firmware; I have a Profi3DMaker, which did not have upgrades since we bought it (4 years ago). Until now, it ran fine!

What did you already try to solve it?
Rebooting, shut off and on again (both the Pi and the printer)

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

Many thanks for help, since printing now is impossible.

Leo.


#2

Update: I did some downgrades, to 1.3.7, and later 1.3.6 I hoped all would be back to last week.
But, same situation.
Then, I removed plugins (I read someone having trouble with Cancel function, who removed plugins and had success).

Rebooted and... GO!

Now only I know that it is either 1.3.8 OR the plugins. I will let this print run, upgrade to 1.3.8 and see what happens, without re-installing the plugins.

PS: I kept the Full screen plugin and the touch UI plugin, just because I love both.

If this info triggers some good diagnosis from your side, I'd like to read from you. Keep you updated,

Leo.


#3

Jay! Upgraded to 1.3.8. once more, kept only plugins for touch UI and full screen, and...
works again!
... with the file that went wrong earlier.

The only thing I can come up with is the incompatibility of one of the plugins.


#4

Thus, removing plugins may solve problems.


#5

Maybe it would be a good idea if you can list the plugins you've removed, so one can experiment a bit to locate the problematic plugin ...


#6

Hi Bernd,
Sure, a good point!
Only problem: I don't have an accurate list. The plugins that seemed nice grew through the months, and this case led to a big cleanup.

But, I'll give it a try, reading through the repository. I had:

  • CR10 levelling
  • display progress
  • display z
  • emergency STOP button
  • Octoprint Youtube live
  • Touchtest bed leveling

One or more of these combined may have caused it.
Leo.