Chrome Disconnecting

What is the problem?

I can only access octoprint after restarting my computer and re-opening chrome. I am able to do about 3 to 4 things in octoprint before it stops sending commands to my printer. I can move around octoprint, but it behaves as if it's not connected to Klipper.

What did you already try to solve it?

I restarted both my printer and my computer.

Have you tried running in safe mode?

I can't even get enough commands to get there before Octoprint stops connecting to Klipper (but it looks like it's still connected because I still see all of the responses from the printer in the command section)

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

I can't get on long enough to do this.

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Voron 2.4 r2 running most current version of Klipper. Chrome browser on Windows computer.

I'm a bit confused as to exactly what the problem is here. You seem to describe it as the OctoPrint <-> Klipper connection is not working, but also that you can't use OctoPrint's UI for more than a couple of seconds to do things like running in safe mode or getting a system info bundle.

Normally when the printer is not connected (here when OctoPrint is not connected to Klipper) then it shows as 'offline' in the sidebar, but freely allows you to use the rest of OctoPrint's UI. What is stopping you doing this? Is there a message that blocks it or does it just become unresponsive?

I am having the "same" issue.

What is different is I am running Marlin 2.1.2. It is not a constant issue. It seems leaving Chrome page open, unattended for some time is the issue. When you get back to the page nothing works. Sometimes you even have to restart the Pi4 I use to get Octoprint running again.
Very annoying with long prints if you cant monitor properly.
It is definitely a problem with Chrome browser.
I get around it using my iPhone but the small screen is a issue for me.
Hope this helps....

The first thing that comes to my mind is have you tried other browsers? Is it Chrome itself or a Chrome extension that is causing the problem? What time frame are we talking about?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.