Communication Error causing Zits

What is the problem?

Hi there!

I am new to the Octoprint world, using octo4a which I know isn't the ideal but, I am very excited about how it will change my workflow but am getting issues with blobs and pauses accompanied by the following in the serial logs:

Communication timeout while printing, trying to trigger response from printer. Configure long running commands or increase communication timeout if that happens regularly on specific commands or long moves.

What did you already try to solve it?

  • Literally every baudrate. I read that maybe that could cause it, in the config I believe its set to 115200, which is the default octoprint finds when I set it to AUTO
  • Turning the camera server on and off. I read a forum post about camera resolution slowing things down
  • ArcWelder plugin on and off
  • Manually keeping the screen alive the whole print
  • 2 different USB c hubs, and a simple usb c adapter
  • Unshielded and shielded USB cable
  • Turning of all over electronics in the room except the printer
  • Using a very simple model, vase mode cylinder
  • Using safe-mode, no change

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle (1.0 MB)

Additional information about your setup

Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ... as much data as possible

  • BIQU B1 SE Plus running standard firmware from their github. They do have their configuration, if its necessary I can upload here.
  • Samsung Galaxy S10 - not rooted. Turned off all battery optimisations I could find, increased screen time to be on maximum (only 15 minutes).
  • Shielded data USB cable (with tape over the power pin just in case).

Further update!

I tried installing Octoprint on my mac and it worked flawlessly. Well at least the first test went without any pauses so that makes me believe the problem is on the phone / server side and not the printer or the USB cable.

I know Octo4a isn't specifically supported, I've posted my question on the github page there too but I was just hoping someone could offer insight!