Communication Error over ethernet and wifi

What is the problem?

After moving printer and disconnecting Pi constant communication errors. When I re image the Pi I cant complete connectivity checks.

What did you already try to solve it?

Replaced SD card, Cables, Power supply. Tried to set up network in txt file as shown in the FAQ section. Updated printer firmware. Tried using ethernet connection. Re imaged Pi.

Have you tried running in safe mode?


Did running in safe mode solve the problem?

No the same problems still are present.

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/92.0.4515.131 Safari/537.36 Edg/92.0.902.67
connectivity.connection_ok: false
connectivity.enabled: true false
connectivity.resolution_ok: false
env.hardware.cores: 4
env.hardware.freq: 1400
env.hardware.ram: 915718144
env.os.bits: 32 linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 3 Model B Plus Rev 1.3
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.throttle_state: 0x80000
env.python.pip: 20.3.3
env.python.version: 3.7.3
env.python.virtualenv: true
octoprint.safe_mode: true
octoprint.version: 1.5.2

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Using Prus I3 MK3S+, Pi 3

Any help is appreciated.

Could you clarify what you mean by 'communication errors'? Commonly when people reference these the problems are reported by OctoPrint between OctoPrint and the printer. But it sounds like you might be talking about the WiFi/internet connection?

Hello thanks for your response

I have included a picture of the error I am currently getting.

Ok, so that is nothing to do with the internet connection or WiFi. This is between your printer and OctoPrint, over the USB cables. Make sure in the printer's LCD menu that the setting 'RPi Port' is set to 'OFF'. This is for connecting the Pi over the GPIO pins. It's not very clearly named... Check it is set to off.

That worked.

Thanks so much such a simple thing but very counter intuitive.