Communication error with CoipyMaster 300 v2

What is the problem?

Got a new printer (CopyMaster 300 v2), new RPi 3+. Sliced files from S3D print great from the card. When printing from OctoPrint, I get something similar to "There was a communication error while talking to your printer. Please consult the terminal output and octoprint.log for details. Error: Printer keeps requesting line 1276 again and again, communication stuck"

The line number is different but I get it early on in every print.

What did you already try to solve it?

New USB cable, changed port, re-sliced file, tried different file.

Complete Logs

octoprint.log (227.8 KB)


Additional information about your setup

Octoprint 1.4.0
Ocotpi 0.17.0
Pi 3b+



Is this new USB cable a high quality one (thick and with ferrite beads on both ends)?
It also should be as short as possible. Keep it away from power supplies and stepper motors.

Please also enable the serial.log and share this.

Also try without the plugin "Octoprint-Display-ETA". The colon in the line can cause trouble in the firmware.

Hi! So both cables I tried were new that came with 2 different printers, they had 1 ferrite bead.

I enabled serial log and I disabled ETA plugin and tried re-printing. Guessing it was the ETA plugin as the print has got further than any other so far!

Edit: scratch that. I didn't get any errors, but the print head would randomly move away from the print and I got bad layer shifts! Let me know if you can find any other issues.

octoprint.log (3.1 MB) serial.log (148 Bytes)

1 Like