Communication problems with Anycubic Chiron and Octoprint/Raspberry Pi

What is the problem?
Anycubic Chiron drops serial connection to Raspberry Pi.

What did you already try to solve it?
Bought new power supply made for Raspberry Pi (5v, 3 amp).
Changes Cable tp Printer (Shielded and worked with the other printer, no errors)
Updated to latest Octoprint
Update to latest firmware at Anycubic
Re-flashed SD card for buster-lite and setup multiple printers thru putty.

Logs (syslog, dmesg, ... no logs, no support)
serial.log (289.9 KB)
octoprint.log (86.0 KB)
Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)Raspberry Pi connected to Chiron via USB. Second printer also connected via USB to same Pi, no disconnects. Running Octopi buster lite 0.17.0. latest firmware from anycubic website. Windows 10 on my computer connected to Pi via network, no issues. I'm not super tech savvy, but hope I've provided what is necessary for suggestions.

I moved it to Get Help because it's not a Network issue.

There are some bad things going on on the serial connection.

2020-11-25 20:29:00,360 - octoprint.util.comm - WARNING - Received line:
2020-11-25 20:29:00,361 - octoprint.util.comm - WARNING - | ‰6•û“e\x00"4’@ùÖ%²DÙÑdEDóÀ›ffVü¶I[ @"ªº •˜¶ð©h»ÂՉ³
‘„•Cb*@¥3)¦5z*´>eL¸“i¾€ô"Dý" F€‘#Ò^É]ÐIZ…h>\x00DF "à"D|$„Ë
æ`ə÷aö%†Ë"  ÿDZAՙ¦k@̛/€¬¦B4¢
•"BÀ$‰¨º Z'‘·AÕЉ"- £`Zƒ‹"%\x00§]hO¯ÀK42` Ü-\x00'ÝVÀ%\x00Î2VÀ%ZK‚2þ"D,D-DF"}‘DXááÕ
7¾€"@BÐF " º&1} «ºe²H˙2˄™­K•"D #ø‘ªÂ¾€ÀÍ$ô٢铧ÍM²Kh’Q‹K%?Z%I•sЪ“Àé"_6øõ”ÿL’û—ÐMñɚ·ÅŠ¹âecho:Unknown command: ""
2020-11-25 20:29:00,366 - octoprint.util.comm - WARNING - The received line contains at least one null byte character at position 6, this hints at some data corruption going on

I assume you already read this:

Also some electrical devices in your home can cause issues via the power line. Some are microwaves, fridges, power drills...

Yes, I had read that post, thus purchasing a new power supply and changing printer cables. Also, the only thnigs running in the entire house is a refrigerator and a freezer, both on different circuits and my computer, also on a different circuit. That's one reason this is driving me nutty. The usb cable from the Pi to the printer is routed away from the printer as much as possible. Could firmware be a possible problem? I read somewhere on-line there was a problem with a Raspberry Pi and Anycubic firmware, but can't find the article now. The configurating I'm currently running, worked perfectly for months, then for some unknow reason it started dropping the connection. This has been going on now for about 4 months and it's driving me nutty. I've googled everything I can think of, read all the posts on the forum, and checked out Reddit. My Anet A8 never loses it's connection to this same Pi which has a 2nd instance of Octoprint running on port 5000, with the Chiron running on 5001. The Pi is dedicated to Octoprint and these 2 printers.

Have you tried this plugin?

Already tried with the A8 disconnected?

Instancing is possible, but not really recommended.

Yes, the problem exists whether or not the Anet is connected. I'll try this fix tomorrow. My poor old brain needs to relax for a while. lol. Thanks very much for your suggestions. What would you suggest other than running a 2nd instance of OCtoprint? I've thought of getting another Pi, but the problem exists even if the Chiiron is the only thing running, so doubt if another would be the answer. I've also thought about trying to get Octoprint to run on an older Windows computer that I have. I'd really like to continue to use it.

Could not wait until tomorrow to try this out. Installed this plug-in tonight and started a new print. Five hours in, and almost finished, worked perfectly. You are a genius. Wish I had post this before. Would have eliminated a lot of pain and anguish over the last few months, not to mention the loss of a lot of filament. Print just finished. Thank you so very much for solving this problem for me.

1 Like

Great! I'll pass the honour on to @foosel who wrote this plugin.

So could you please:

PSA: Please mark the solutions to your topics as such

Solved. Hope I did this right. My first time posting a problem, so am unfamiliar with process.

1 Like

Well, looks like I spoke too soon. Tried to print the same piece I printed last night, started getting disconnects again. Reloaded the CBD plugin and tried again, same thing several times. About the only thing left is replace the Pi, or put a meter on the electrical outlet, which I will do after the holidays. For now, I think I'm going to try to get Octoprint running on an extra computer I have and dedicate it as the print server. Many thanks again for your support.

Well, looks like I have found the solution, quite by accident. (make my best discoveries that way.) While looking for something else yesterday, I ran across a post bu Foosel that said to put a tiny piece of electricians tape on the 5v pin of the USB cable. Didn't have much hope of it fixing my connection issues. Much to my surprise, I ran a 4 hour print last night successfully. Today, 2 hours into am 8 hour far so good. My appreciation to you Mr. Ikemann for all your help last week, and especially to foosel. Hard to believe that after replacing the power adapter 4 times, and the USB cable at least a dozen times, that a tiny bit of tape solved the problem. But it did.