"Communication timeout while idle" after doing a PID Autotune


#1

What is the problem?

After doing a PID Autotune I get this message

Communication timeout while idle, trying to trigger response from printer. Configure long running commands or increase communication timeout if that happens regularly on specific commands or long moves.

What did you already try to solve it?
N/A

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

OctoPrint version 1.3.9
OctoPi version 0.15.1
printer = wanhao i3
firmware = marlin bugfix-2.0.x

terminal tab

Recv: bias: 95 d: 95 min: 211.25 max: 219.17 Ku: 30.56 Tu: 34.11
Recv: Classic PID
Recv: Kp: 18.33 Ki: 1.08 Kd: 78.17
[...]
Recv: bias: 95 d: 95 min: 211.87 max: 219.17 Ku: 33.18 Tu: 33.79
Recv: Classic PID
Recv: Kp: 19.91 Ki: 1.18 Kd: 84.08
Communication timeout while idle, trying to trigger response from printer. Configure long running commands or increase communication timeout if that happens regularly on specific commands or long moves.
[...]
Recv: PID Autotune finished! Puok T:175.00 /0.00 B:23.12 /0.00 @:0 B@:0
Communication timeout while idle, trying to trigger response from printer. Configure long running commands or increase communication timeout if that happens regularly on specific commands or long moves.
[...]
Send: M500
Recv: echo:Settings Stored (577 bytes; crc 31129)
Recv: ok
[...]


#2

What did you already try to solve it?
N/A

You should do as it suggests and set your long running command (your PID tune command) as a long running command. It's somewhere in octoprint's settings, I think maybe serial, in an advanced dropdown, sort of hidden section. I don't currently have octoprint running anywhere to check exactly where it is. Set your PID command (just the M or G code, not the whole thing with the S and the B and the T and P) as a long running command so octoprint knows that when that command is run, the printer isn't likely to respond during it.


#3

Yeah I read that bit, I didn't how to do what it said.

Can you post a screenshot with the command/s?
It will make it easier to understand...


#4

As I said, I don't currently have octoprint running anywhere to get to it, but I can do it later. I'm pretty sure it's in like, settings -> serial? I think? and then scrolling down to the bottom there's an advanced hidden settings menu you can click on.

I'll fire up octoprint later and take a look & a screenshot.

edit: Ok, it's in settings -> serial connection -> firmware & protocol

Scroll down and you'll see protocol fine tuning, and right at the bottom you'll see "Advanced options", click that text and new options will appear, in the long running commands, you can enter your PID tune command, which according to this: https://reprap.org/wiki/G-code#M303:_Run_PID_tuning is M303, so you'd just add M303 on to the end of the existing commands.