Communications Error

I found and read your post on Feb 15 about a Communication error where you told them to replace G28 x Y:Home XY with G28 X0 Y0;Home XY.
I use Simply3D so I went in to it and went to the Start script and replaced G28;Home all axis which is what was in mine script to G29 X0 Y0;Home XY but I still get the same error when I tried to print the file.
I can connect my pi/Octoprint with no problem to my printer which is a one day old Monoprice Make Select Pro Ultimate 3D Printer. I can control and move X,Y,Z, the extruder and turn the bed and hot end heat on and off.
This is the error I get- image I am really at a lose This is my fifth printer all my printers have their own Raspberry PI 4 B with 4Gigs of ram and are running the latest version of Octoprint.

octoprint (2).log (27.1 KB)

Please let me know if there is anything I can do to help - I really need to get this working or know if I need to return this printer.



Could you please also share the serial.log for this issue belongs to the serial connection.
You may have to activate the serial logging first.

| Send: N3 M117 ETA: -*96
| Recv: Error:No Checksum with line number, Last Line: 2
| Recv: Resend: 3

Your firmware hiccups on the : in the M117 there. I guess that's from some plugin, one of your many Display* ones. You need to get rid of that colon.

Your firmware reads a : as a command separator and tries to split the line on : into two commands. One then has a line number but no checksum, the other has a checksum but no line number.

You can try replacing the : with a \: but YMMV.

serial (1).log (740 Bytes)

Thank you for your reply. You are way over my head with how to remove or change the : after the M117 command.
But i can remove all the 3rd party plugins and see if I can communicate.
if I can then I can add them back two or so at a time to see if I can find the plugin.

It's the Display ETA plugin that's causing your issue and from the looks of it the : is sadly hardcoded. Uninstall the plugin for now, open a ticket in the plugin's repository and request the ability to configure the message that's sent to the printer, to work around issues like this one.

FYI - Turning off all 3rd-party plugins worked I no longer get the Communications error - I have not printed anything yet once it starts to heat up I cancel as I am adding plugins a couple at a time to see if I can find the one or ones causing the error.

Since my plugins work on my other printers I would not think of it being a plugin.


Sorry I miss this I was so eager to tell you it was sort of working- I will do as you say - Thanks again

I am up and working - thanks you very much - I really looked the looks of this printer but did not want to use it if I could not get Octoprint working.

Thank you