Compression/artifacts issue with Octolapse

Camera model

Raspberry Pi Cam v2

What is the problem?

Compression issues (artifacts) with my Pi Cam v2 when using Octolapse. Here is a video showing the issue (at around the 2 second mark)

What did you already try to solve it?

I have tried the default MP4 - 30 FPS profile, a modified version of that which uses 3 of my Pi4's 4 cores and has a bitrate of 15M, yet at some point in every timelapse there is heavy compression artifacts. I do not see this in the normal Timelapse feature in OctoPrint. Viewing the webcam in either MPEG mode or still images at http://octopi.local/webcam/control always looks good, and I have never seen this issue.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (794.7 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

  • OctoPrint 1.9.3
  • Build 2023.10.09.154319 with "camera-streamer", based on OctoPi 1.0.0, running on Raspberry Pi 4 Model B Rev 1.4
  • Voxelab Aquila X2
  • Alex_Marlin_v1.3.5.1 firmware
  • Firefox