Config file does not change camera settings

Camera model
raspi cam v1.2 with ir
What is the problem?
no matter what I change is the config file the log output stays at the default resolution fps and camera selection
What did you already try to solve it?
I have used 3 different pi's reinstalled octo print on all of them tried changing it using notepad++ as awell as the cmd line also have tried to focus the camera does not help
Logs
webcam log

Starting up webcamDaemon...

--- Configuration: ----------------------------
cfg_file: /boot/octopi.txt
camera: auto
usb options: -r 640x480 -f 10
raspi options: -fps 10
http options: -w ./www-octopi -n --listen 127.0.0.1

Explicitly USB device:

Found video devices:
/dev/video0
/dev/video10
/dev/video11
/dev/video12
/dev/video13
/dev/video14
/dev/video15
/dev/video16
raspi
config file='/boot/octopi.txt':USB device was not set in options, start MJPG-streamer with the first found video device: /dev/video0
<13>Dec 2 12:56:14 root: Starting USB webcam
Checking for VL805 (Raspberry Pi 4)...

  • It seems that you don't have VL805 (Raspberry Pi 4).
    There should be no problems with USB (a.k.a. select() timeout)
    Running ./mjpg_streamer -o output_http.so -w ./www-octopi -n --listen 127.0.0.1 -i input_uvc.so -r 640x480 -f 10 -d /dev/video0
    MJPG Streamer Version: git rev: 5554f42c352ecfa7edaec6fc51e507afce605a34
    Done bring up all configured video device

Goodbye...

i: Using V4L2 device.: /dev/video0
i: Desired Resolution: 640 x 480
i: Frames Per Second.: 10
i: Format............: JPEG
i: TV-Norm...........: DEFAULT
UVCIOC_CTRL_ADD - Error at Pan (relative): Inappropriate ioctl for device (25)
UVCIOC_CTRL_ADD - Error at Tilt (relative): Inappropriate ioctl for device (25)
UVCIOC_CTRL_ADD - Error at Pan Reset: Inappropriate ioctl for device (25)
UVCIOC_CTRL_ADD - Error at Tilt Reset: Inappropriate ioctl for device (25)
UVCIOC_CTRL_ADD - Error at Pan/tilt Reset: Inappropriate ioctl for device (25)
UVCIOC_CTRL_ADD - Error at Focus (absolute): Inappropriate ioctl for device (25)
UVCIOC_CTRL_MAP - Error at Pan (relative): Inappropriate ioctl for device (25)
UVCIOC_CTRL_MAP - Error at Tilt (relative): Inappropriate ioctl for device (25)
UVCIOC_CTRL_MAP - Error at Pan Reset: Inappropriate ioctl for device (25)
UVCIOC_CTRL_MAP - Error at Tilt Reset: Inappropriate ioctl for device (25)
UVCIOC_CTRL_MAP - Error at Pan/tilt Reset: Inappropriate ioctl for device (25)
UVCIOC_CTRL_MAP - Error at Focus (absolute): Inappropriate ioctl for device (25)
UVCIOC_CTRL_MAP - Error at LED1 Mode: Inappropriate ioctl for device (25) UVCIOC_CTRL_MAP - Error at LED1 Frequency: Inappropriate ioctl for device (25) UVCIOC_CTRL_MAP - Error at Disable video processing: Inappropriate ioctl for device (25)
UVCIOC_CTRL_MAP - Error at Raw bits per pixel: Inappropriate ioctl for device (25)
o: www-folder-path......: ./www-octopi/
o: HTTP TCP port........: 8080
o: HTTP Listen Address..: 127.0.0.1
o: username:password....: disabled
o: commands.............: disabled
Starting up webcamDaemon...
config file

Windows users: To edit this file use Notepad++, VSCode, Atom or SublimeText.

Do not use Notepad or WordPad.

MacOSX users: If you use Textedit to edit this file make sure to use

"plain text format" and "disable smart quotes" in "Textedit > Preferences"

Configure which camera to use

Available options are:

- auto: tries first usb webcam, if that's not available tries raspi cam

- usb: only tries usb webcam

- raspi: only tries raspi cam

Defaults to auto

camera="raspi"

Additional options to supply to MJPG Streamer for the USB camera

See https://faq.octoprint.org/mjpg-streamer-config for available options

Defaults to a resolution of 640x480 px and a framerate of 10 fps

camera_usb_options="-r 1280x720 -f 15"

additional_brokenfps_usb_devices=("aabb:ccdd" "aabb:eeff")

If this fixes your problem, please report it back so we can include the device

out of the box: Issues · guysoft/OctoPi · GitHub

#additional_brokenfps_usb_devices=()

Additional options to supply to MJPG Streamer for the RasPi Cam

See https://faq.octoprint.org/mjpg-streamer-config for available options.

NOTE: Newer raspi cam modules are reporting as usb devices causing these

options to be ignored. Set camera="raspi" to avoid these issues.

Defaults to 10fps

camera_raspi_options="-x 1280 -y 720 -fps 20"

Configuration of camera HTTP output

Usually you should NOT need to change this at all! Only touch if you

know what you are doing and what the parameters mean.

Below settings are used in the mjpg-streamer call like this:

-o "output_http.so -w $camera_http_webroot $camera_http_options"

Current working directory is the mjpg-streamer base directory.

#camera_http_webroot="./www-octopi"
#camera_http_options="-n"

EXPERIMENTAL

Support for different streamer types.

Available options:

mjpeg [default] - stable MJPG-streamer

hls - experimental FFMPEG HLS streamer

#camera_streamer=mjpeg

Additional information about your setup (OctoPrint version, OctoPi version, ...) newest version of octoprint running on raspi 3b+ hope yall can help

And what other settings have you tried changing to that are not working? You saved the changes to that file and then rebooted your pi? The settings your changed were valid settings?
May I ask why you're using an IR camera? I wouldn't think that would work very well, not with all the heat coming off the hotend and the bed.

If you are changing the config file in Notepadd++ on a Windows machine, you also have to change the EOL setting to UNIX. Otherwise your are doing to get nasty formatting on your file, causing it to trash the file and use the default again. If Octoprint detects a bad config it will just use the defaults rather than not work at all.

Thanks for responding but I ended up fixing it my go to always fixed everything move which I did not even think of doing (reinstalling octo print completely and have said device connected/file edited before the initial boot and as the printer this ok will be connect to is arriving today reflashing it was not an issue.

As for why IR you can buy pass filters that will filter out ir light (same thing that is applied directly to the sensor on the non ir model) the difference is you can buy one that can only filter ir to an extent meaning the heat from the bed does not affect it yet a high power ir light or such will allow it to see fine in the dark. Why do I need night vision I do not have a dedicated shop and instead of keeping the lights on using this is much more effective.

1 Like

But that's not going to work. If you're going to filter it out then you would need. Source of IR, like a night vision security camera does. If you're going to need a light source anyway, why bother? But hey, you do you.

The printer arrived today and I set it up and it works perfectly. As for the lighting I used an ir led strip and it lights it up just fine.

1 Like