Config.yaml corrupted, how can i start octopi?

What is the problem?

octopi didn't start, no listen on port 5000

What did you already try to solve it?

after many and many check i started octopi manually and i found an error starting due to corrupted config.yaml file.
i don't have a recent backup.
the config.yaml is really corrupted with strange characters.
i created a new file copied from github
now octoprint starts but i cannot login with my user and password. these are corrects.

what do you suggest ?
how can i get a working file ? how can i setup/force the user ?

Have you tried running in safe mode?

no, i don' know i can do this task from CLI

Did running in safe mode solve the problem?


Systeminfo Bundle

Additional information about your setup

octoprint 1.6.1

If one file was corrupted then there are likely more. You're better off re-flashing.

this is also my suppose...

what do you suggest to backup SD ?
what do you use normally ?

i use windows but in case i can try with a Linux VM accessing SD.


The config.yaml file is paired up with a users.yaml file, so you can't just replace one without replacing the other, the logins will not work as the salts don't line up.

i loaded an initial SD backup on my pc. now i have the old files.

one question, is it possible to overwrite all the .octoprint folder ?

one note: the old users.yaml is fine and it is the same of backup

change the SD on my raspberry is not simple because it is into a closed box. it is possible to access but it is not simple.

I have a USB SD card reader/writer. I plug it into my desktop when I want to create a new SD card image and I plug it into my RPi and use rpi-clone to make a backup copy.

i restored the config.yaml and restarted octoprint and now it works fine, i also upgraded sw and printed two 3d modes.

the users.yaml was fine (not corrupted)

do you know the best method to save an image online without remove SD card?
for now i created a tar.gz of entire SD card. just as "another one backup"


If you don't have anything installed on the Pi outside of OctoPrint, creating a backup inside OctoPrint and downloading that should be enough in my opinion.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.