Connected to WiFi can't find the pi at octopi.local

What is the problem?
My octopi is connected to the WiFi and I have it's IP. But it does not show up at octopi.local it just says "we cannot connect to the server at www.octopi.local", it also doesn't show up in the network tab on file explorer. I am using an octo pi 3 b+ and it's onboard wifi, I am also using Windows 10 and the latest version of octo print, and a Logitech webcam
What did you already try to solve it?
I moved it so it is right next to the router and I have reflashed octoprint onto the sd and tried connecting from 2 different mobile devices

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...) It is a Netgear that is a mesh network it is dool band 5ghz and 2.4ghz I am trying to connect to it from a windows computer and 2 different Android devices running Android 9

Hello @William_Reidy!

Please connect to octopi.local - not www.octopi.local
Just type in http://octopi.local to prevent the browser adding a www. at the beginning.

3 Likes

If that fails you will need to use the ip address for the pi. I could never get octopi.local to work on my Windows 10 PC without creating an entry for it in the PC's hosts table, but the ip address works every time.

If you don't know the ip address you should be able to get it from your routers DHCP table. or failing that connect a screen to the pi's HDMI port and boot the pi, you should see something like:

Access OctoPrint from a web browser on your network by navigating to any of:

http://octopi.local
http://192.168.1.100 (your entry here will be different)

And try the last line in your browsers address bar...

The ".local" convention is part of a service called mDNS. This native to macs (it's part of an Apple service called Bonjour). It was traditionally not a service on Windows (because it was created by Apple, but Apple makes it available to everyone and they do have Bonjour for Windows). I seem to recall learning that more recent versions of Windows now include it but you may have to enable it. Do a Google search for "how to enable mDNS on Windows 10".

2 Likes

None of these worked for me

Name-resolution hacks

I had this exact same issue. You get everything setup and try to SSH in and nothing! Here is what I did:

1 ) Hook up your raspberry pi to a monitor, keyboard, and mouse.

2 ) Manually login as "Pi" password "Raspberry" and it should drop you to a prompt.

  1. Type in "hostname -I" and then it should spit out your connection information. Use that IP address to SSH in or just keep the Pi hooked up until you are done setting it up.

If it didn't return an IP address then I suspect it's not actually connected, in which case you need to reedit the supplicant file on the SD card and double check your connection settings.

2 Likes

It let's me type in the login but will not let me type in the password it won't let be type anything in password

The password does not appear on the screen.
If you have another keyboard than "QWERTY" take care to hit the correct letters.

I have a similar problem, except mine is intermittent: "octopi.local: Name or service not known", and sometimes it works perfectly fine.
I can rlogin to the ip address, and if I have it ping itself at octopi.local, then it works, after which I can find octopi.local
At least, that's what happened this time...

So my guess here is that the router needs to learn of the alias, or something like...

I suppose a workaround would be to have the pi to run something at startup, but I've never had great success on the pi with startup programmes.

1 Like

You might read through this to see if anything helps.

Thanks, I'll take a look drekly.

Keying in octopi.local into my Mac browser did nothing, so I connected a screen and keyboard. I have a load of script coming up on the screen, then the prompt. I logged in as pi and raspberry, entered hostname -i, and received 127.0.1.1, but I have no idea where it obtained that from. My SSSID and pw are correctly in the file I flashed. The IP should be 192....etc.

I have no idea what to do now. I would be grateful for any advice.

Roger

hostname -i isn't what you want, try ifconfig and/or iwconfig. Since you have a keyboard and monitor connected, you can also type sudo iwlist scan | grep -i essid and make sure your WiFi is listed.

Thank you. Found the problem. You can't have spaces in the SSID! Attached to my backup network that doesn't and all working now.

Roger

1 Like

Logged into my router. Found the Octopi, clicked edit. Changed it to reserved IP and it worked for me. I'm not a pro but it seemed to fix it for me.

IP 127.0.0.1 is standard for localhost. It's set internal.
It's always a good choice to use IP-adresses before using names to avoid name resolution problems on first tests.
And it's always a good idea to use ping (it's a programm almost on every system available, use google for how to use) to make sure, that another whatever is available on network.

1 Like

Here was what worked for me -
I was previously using this Pi over VNC Viewer and had an IP address reserved on my home network for it.
I was able to ping octopi.local/ but could not connect through a browser at URL or IP.
I removed IP address reservation from Pi and allowed it to use DHCP.
Power cycled Pi was able to connect via octopi.local/

I have a Verizon Fios, G3100 router and found my problem was one of the settings. I have Raspberry PI 3+ and couldn't connect to https://octopi.local or find the IP address on my router. I went in to my router settings and in Network/Wi-Fi/AdvancedSettings/802.11 Mode and changed the default setting which were "Legacy Mode (802.11b/g/n)" to "Compatibility Mode (802.11b/g/n/ax)" in both the 2.4 GHz and 5 GHz and made it work. This also fixed my Wyze security camera/light bulbs and HP paper printer's Wif-Fi issues.

Hello, can someone help me, I am trying to use octoprint to print from my computer or a remote location in the future, to a raspberry pi connected to my printer. I have set up octopi on the raspberry pi but I am having trouble connecting to it from a remote location. http://octopi.local did not work so I attempted to plug a keyboard, mouse, and monitor into the pi. I do this and my monitor displays a message that there is no signal coming from the pi and I have to press the keyboard to wake it up. I do so and it does not work. This is the only way I am able to find the IP address of my Pi. How would I fix this. Also, what would I do once I have the IP address? Thank you for your help in advance