Connecting error Pi ZERO prusa mk3

What is the problem?
It seems the PI zero doenst connect to the printer
Connecting to: /dev/ttyAMA0
Changing monitoring state from "Offline" to "Opening serial port"
Connected to: Serial<id=0xaf80ac70, open=True>(port='/dev/ttyAMA0', baudrate=115200, bytesize=8, parity='N', stopbits=1, timeout=10.0, xonxoff=False, rtscts=False, dsrdtr=False), starting monitor
Changing monitoring state from "Opening serial port" to "Connecting"
There was a timeout while trying to connect to the printer
Changing monitoring state from "Connecting" to "Offline"
Connection closed, closing down monitor

I have followed all the instructions
make two raspi zero W but nothing happens
I activate the debug on logs but there seems to be no error message to work with

What did you already try to solve it?

I installed different versions of octopi, upgrade the soft both from octopi and the raspi, reinstalled the last version of prusa firmware, and still the same timeout message

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, what kind of hardware precisely, ...)

OS Release Notes

cat /etc/os-release

PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
NAME="Raspbian GNU/Linux"
VERSION="10 (buster)"

Version of Debian

cat /etc/debian_version

Kernel Version

uname -a
Linux octopi 4.19.75+ #1270 Tue Sep 24 18:38:54 BST 2019 armv6l GNU/Linux

#check version
cat /proc/cpuinfo

processor	: 0
model name	: ARMv6-compatible processor rev 7 (v6l)
BogoMIPS	: 697.95
Features	: half thumb fastmult vfp edsp java tls
CPU implementer	: 0x41
CPU architecture: 7
CPU variant	: 0x0
CPU part	: 0xb76
CPU revision	: 7

Hardware	: BCM2835
Revision	: 9000c1
Serial		: 0000000090fd614a
Model		: Raspberry Pi Zero W Rev 1.1

OctoPrint 1.4.0 running on OctoPi 0.17.0


dwc_otg.lpm_enable=0 console=tty1 root=PARTUUID=6c586e13-02 rootfstype=ext4 elevator=deadline rootwait


# For more options and information see
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border

# uncomment to force a console size. By default it will be display's size minus
# overscan.

# uncomment if hdmi display is not detected and composite is being output

# uncomment to force a specific HDMI mode (this will force VGA)

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display

# uncomment for composite PAL

#uncomment to overclock the arm. 700 MHz is the default.

# Uncomment some or all of these to enable the optional hardware interfaces

# Uncomment this to enable infrared communication.

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)

# Enable DRM VC4 V3D driver on top of the dispmanx display stack

# enable raspicam

Any idea will be more than welcome!

Hello @Guillermo_Blanco!

Keep in mind that a Raspberry Pi zero/zero-w is not recommended for running OctoPrint.

If you are using the internal connection, you have to setup the printer firmware accordingly:

And please share the logs. Even if you do not see an error. Most important in this case is the serial.log

Hi thanks,

yeap already did the RPi port ON via the printer

octoprint (18).log (306.0 KB) serial (15).log (2.0 KB)

An update on this. I'm still having the same issue with the raspberry pi zero W and the einsy but I tried to connect a raspberry B via usb and it works. It seems that there is an issue with either the Tx Rx, the einsy that doesn't take into account the option RPi ON or the raspi zero W. As there are some users that got their W work I presume my einsy is having some sort of problem...

Whatever other users or Prusa Research say, you really should not use a Zero W anyhow. That thing is just one larger wifi utilization away from starving and ruining your print jobs. It's simply not up for the job.

And every time I write that someone comes in and goes "oh, it work great for ME, you are mistaken" and all I can say to that is "whatever, no one forces you to follow the recommendation from the person who wrote OctoPrint in the first place, but don't open tickets when you run into stuttering issues".

Final update on this and now a closed issue!

Ok so I found the problem ! hope this can help some of you having this same issue.
The Einsy Rambo board has two Tx Rx pins, one from J19 socket (RX1 and TX1 - the ones used by the Pi Zero W and the other ones from Ext P3 socket which are in the first row of the socket where the fill sensor is connected (TX2 RX2). If by mistake your fill sensor is connected to the first row instead of the second, you will have two main problems: first your fill sensor will not work and second your pi zero will not connect with the printer :slight_smile:

1 Like