Connecting OctoPrint to eduroam Wifi

What is the problem?
Can't connect octoprint to my eduroam wifi.
What did you already try to solve it?
Tried putting in the WPA-Enterprise specific lines in wpa-supplicant. Tried making ethernet static ip. Tried editing
Logs (syslog, dmesg, ... no logs, no support)

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)

I currently have a printer and an instance of octoprint running well on my school's wifi, eduroam. The wifi specifications are seen below.

Screenshot 2021-02-02 112222

I am attempting to setup another RPi for my second printer. I initially thought just editing the relevant conf files on my new SD card to match my old working one would work but it didn't. I then tried putting my old working SD card into my new Pi and it works so I know it's not a broken Pi. So now I'm confused what I'm missing on my new SD Card.

This is the order I have changed things on a fresh OctoPi install. (I didn't change anything in windows before these steps)

  1. I SSHed into the new Pi using an ethernet cable and changed the locale to "en_US.UTF-8 UTF-8" and the timezone and wifi country to US.

  2. I went into wpa-supplicant, deleted everything in it and added the lines below. (The username and password are correct in the real thing)

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=US
network={
ssid="eduroam"
proto=RSN
key_mgmt=WPA-EAP
identity="my school username"
password="my school password"
phase1="peaplabel=0"
phase2="auth=MSCHAPV2"
}

  1. I went into dhcpcd.conf and uncommented these lines

profile static_eth0
static ip_address=192.168.1.23/24

  1. I shutdown OctoPi and unplugged the ethernet and power. Then I powered up the raspberry pi again and waited a few minutes. Plugged my ethernet back in and it still hadn't connected to the wifi.

I've also tried a using a bunch of different lines for wpa-supplicant, interfaces, and dhcpcd suggested to work for eduroam on the internet. This is one of the most comprehensive ones I tried (Reddit). Also I know I can just clone the SD card to my new one but I would like to figure out how to do it so I can connect non octoprint RPi instances to the wifi as well. Lastly I have a Win32DiskImager cloning file for my old working SD card in my google drive if people are curious enough. Thank you all!

What kind of Pi are you using? I'm hoping it a Pi 4, because a Pi 3 or 3+ doesn't support 5ghz wifi, only 2.4 ghz.

When you say it's not connecting, are you connecting a keyboard and monitor to the Pi? If you are plugging in the ethernet, then it's not going to connect to wifi. The pi4 has a gigabit ethernet port so it's going to be a lot faster.

It does connect to both, helpfully... Caused me some pain when the same Pi ended up with multiple IPs because it would connect to both wifi and wired.

Hi ryan780 thank you for your responses. I am running a 3b and 3b+ however the "eduroam" network I'm trying to connect to over wifi has both 5ghz and 2.4ghz bands:

Screenshot 2021-02-04 104715

I am trying to get it to connect to the wifi and then sshing through an ethernet cord.
Is there something I need to change on octoprint's side to tell it to connect to the 2.4ghz band of eduroam instead of the 5ghz band? Thanks