Connecting Snapmaker J1 to Octoprint

I have a Snapmaker J1 since recently and want to use it with Octoprint.
Octoprint works fine (with my Anet A6), I can connect the J1 with the USB cable to my Linux server running Octoprint and, when switched on, it shows up in the list of ports, but it just won't connect. Log:

Changing monitoring state from "Offline" to "Opening serial connection"
Connecting to port /dev/ttyUSB0, baudrate 115200

But nothing more. Do I need some setting on the printer or on the server maybe? I'm a bit stuck actually.
I can print with Luban, over wifi, and I can also use the Cura plugin and send gcode files over wifi from that. So ingredient seems working, but I cannot get it integrated in Octoprint.

  • Snapmaker J1 (latest firmware: v2.5.13)
  • Octoprint 1.9.0
  • host: Debian Linux 11
  • USB-serial connection
    In the end, I'd rather use WiFi, but that may be too far fetched for now (however, Cura can send files over WiFi). Being able to print and monitor progress in Octoprint would be my goal.

to the printer?

Sounds like the printer has a wifi module on the board itself and allows for sending files across it. Typically in that scenario the firmware is using a serial connection from the wifi module to the board. We recently discovered with the Prusa MK4 that having this connection enabled killed the ability to connect locally over USB. Your printer could potentially be in the same situation and disabling the wifi module on the printer may allow for the USB connection.

1 Like

If that doesn't work the only other way I can think of connecting would potentially be using this plugin, which will send the gcode from OctoPrint over the wifi to your printer. This could potentially be very sketchy and you would want to insure a stable network connection.

1 Like

Yes, directly to the printer. I think the printer then stores them locally, and I have to select the print file and start to print it from the touchscreen on the printer.
I'd prefer Octoprint and start the print remotely, printing from the server. Preferably over WiFi, but otherwise via USB.

I will try this. Thanks.

Alrighty.
I googled a bit and found other people using this printer with octoprint - it should work fine.
I also found the Marlin source of their firmware.

Even if a wifi connection works - personally I wouldn't do it. A simple reconnect that takes 2-3 seconds could result in ugly blobs.

If @jneilliii suggestion doesn't change anything, could you maybe test it with a spare pi or on another device like a pc / laptop? (you can use pronterface for the testing so you don't have to install OctoPrint)
Just to rule out a software issue with the server.
Also make sure that you don't run any other software (like cura) that could claim the usb connection).

I was also surprised to see that on a Marlin based board - but the website mentions that the screen is more or less an android tablet. Maybe they're doing it that way.
Seems like the Marlin wifi support isn't enabled in the firmware.

1 Like

It appears that WiFi and the serial port are not excluding each other, but the problem was on the Octoprint server side:
The serial port interface /dev/ttyUSB0 was not permitted by the user running Octoprint. A simple sudo chmod 777 /dev/ttyUSB0 did the trick.

ah, you must not be using an octopi image. the manual install instructions even add the user that runs the OctoPrint daemon to the appropriate groups to give them permission to all serial ports.

that's the hack - the correct solution would have been

sudo usermod -a -G tty username
sudo usermod -a -G dialout username

but as long as it works it doesn't really matter ^^

Next step: getting HOST_ACTION_COMMANDS to work, probably need to re-compile the Marlin firmware for that.
And I'm looking for good slicer profiles for the J1 for PrusaSlic3r.

Yeah you probably have to. People already asked for that feature in the forum a lot and they just don't care

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.