Connection is interrupted as soon as print job is started


I have a problem with Octoprint:

What is the problem?

As soon as I start printing with the "print" button, the printer disconnects, or its relay is triggered to open. Any idea what this can be?

What did you already try to solve it?

Rebooted the system, tried different models.

Have you tried running in safe mode?

I can't try, I can't control the relay to power the printer in safe mode.

Systeminfo Bundle (83.6 KB)

Additional information about your setup

Octoprint 1.8.4 / Ender 3 / Raspberry 4 / Relay to switch printer power on and off at GPIO27.
Log when "print" is pressed:


Changing monitoring state from "Offline" to "Detecting serial connection".
Performing autodetection with 1 port/baudrate candidates: /dev/ttyUSB0@115200
Trying port /dev/ttyUSB0, baudrate 115200
Connecting to port /dev/ttyUSB0, baudrate 115200
Handshake attempt #1 with timeout 2.0s
Connected to: Serial<id=0xa7bcc7f0, open=True>(port='/dev/ttyUSB0', baudrate=115200, bytesize=8, parity='N', stopbits=1, timeout=2.0, xonxoff=False, rtscts=False, dsrdtr=False), starting monitor
Send: N0 M110 N0125
Recv: start
Changing monitoring state from "Detecting serial connection" to "Operational
Send: N0 M110 N0
Recv: echo: External Reset
Recv: Marlin 1.1.6
Recv: echo: Last Updated: 2018-11-28 | Author: (Ender-3)
Recv: echo:Compiled: Jan 27 2019
Recv: echo: Free Memory: 9994 PlannerBufferBytes: 1232
Recv: echo:TF init fail
Recv: echo:TF init fail
Recv: ok
Send: N1 M11539
Recv: FIRMWARE_NAME:Marlin Creality 3D SOURCE_CODE_URL:GitHub - MarlinFirmware/Marlin: Marlin is an optimized firmware for RepRap 3D printers based on the Arduino platform. | Many commercial 3D printers come with Marlin installed. Check with your vendor if you need source code for your specific machine. PROTOCOL_VERSION:1.0 MACHINE_TYPE:Ender-3 EXTRUDER_COUNT:1 UUID:cede2a2f-41a2-4748-9b12-c55c62f367ff
Recv: Cap:EEPROM:1
Recv: Cap:PROGRESS:0
Recv: Cap:PRINT_JOB:1
Recv: Cap:Z_PROBE:0
Recv: ok
Send: M21
Recv: echo:TF init fail
Recv: ok
Send: M105
Recv: ok T:19.34 /0.00 B:21.02 /0.00 @:0 B@:0
Send: M155 S2
Recv: ok
Recv: T:19.34 /0.00 B:20.86 /0.00 @:0 B@:0
Recv: T:19.34 /0.00 B:21.09 /0.00 @:0 B@:0
Recv: T:19.34 /0.00 B:20.98 /0.00 @:0 B@:0
Recv: T:19.34 /0.00 B:20.86 /0.00 @:0 B@:0
Recv: T:19.34 /0.00 B:21.02 /0.00 @:0 B@:0
Recv: T:19.26 /0.00 B:20.90 /0.00 @:0 B@:0
Changing monitoring state from "Operational" to "Starting".
Send: N0 M110 N0
Recv: ok
Changing monitoring state from "Starting" to "Printing
Send: N1 M140 S7083
Recv: ok
Send: N2 M105
Recv: ok T:19.34 /0.00 B:20.86 /70.00 @:0 B@:0
Send: N3 M190 S70*92
Recv: T:19.34 /0.00 B:20.86 /70.00 @:0 B@:0 W:?
Unexpected error while reading serial port, please consult octoprint.log for details: SerialException: 'device reports readiness to read but returned no data (device disconnected or multiple access on port?)' @
Please see OctoPrint randomly loses connection to the printer with a "SerialException" - FAQ - OctoPrint Community Forum for possible reasons of this.
Changing monitoring state from "Printing" to "Offline after error".
Connection closed, closing down monitor

You can simulate an always on status by connecting the relay input to the +3.3V rail.
Or just connect the printer direct to the mains.

What do you have in the OctoPrint Start GCODE sequence?

You have some physical buttons plugins installed (Physical Button, ShutdownButtonLEDBuzzer, etc) how are the GPIO ports designated? How is the wiring?

its empty:

i use the following plugins:

  • OctoRelay -> but everything disabled for testing
  • ShutdownButtonLEDBuzzer -> only LED and buzzer enabled
  • PhysicalButton with the following configuration

The button "Printer on/off and connect" uses the following activities:

Sorry..cant edit my posting before:


i have bypassed the relay. The printer now prints as desired, but the relay can still be heard...something in the settings seems to be messed up.

The relay is not activated (i.e. closed) if it was opened when the print was started.
However, it will be opened if it was closed. strange :confused:

seems to be solved. the plugin OctoRelay, although everything is deactivated in the settings of the plugin, it seems to still have executed commands in the background. i have now removed the plugin and everything runs as it should

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.