Connection Refused after upgrade to 1.7.2

What is the problem?

After upgrading Octopi to 1.7.2 I can no longer upload from SuperSlicer directly.

No matter what I've tried Octoprint is refusing the connection.

What did you already try to solve it?

I ran the test from SuperSlicer to check the IP address and API Key. The test failed.

I looked at the API Key in the Octoprint UI and noticed that the Global API key was deprecated. I generated an application Key and tried that from SuperSlicer with the same result.

I then restarted Octoprint an tried again with the same result

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)
haproxy.log (113.2 KB)
octoprint.log (70.3 KB)
plugin_pluginmanager_console.log (11.3 KB)
plugin_softwareupdate_console.log (161.5 KB)
plugin_softwareupdate_update.log (1.7 KB)
serial.log (28.3 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint Version 1.7.2
Octopi Version 0.18.0, running on Raspberry Pi 3 Model B Rev 1.2
Safari running on MacOS 12.1 on Mac mini M1

It looks like this is a Super Slicer problem, although I used the browse button in their printer settings UI to find the Octoprint instance it picked up the wrong IP address. As I type this it occurs to me that the solution is to give the raspberry pi a dhcp reservation in my router.

That's ideal, especially if you don't have the rpi running constantly. It may be getting a different address each time it connects. On top of that, your computer is also likely caching name->address request results.

As such, it's not even really a SuperSlicer problem, as you probably connected fine using the name earlier, the computer cached that address, and then when you tried to connect after upgrading it returned the same cached address.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.