Control Tab Lock Up Octoprint

What is the problem?

My octoprint build is running in a Python3 venv on a Dell Optiplex 3020. It's been running flawlessly now for about two days, until today where the system locked up completely when starting a print. Now every time I enter the control tab the system locks up, but if I click out and wait about a minute for it to refresh and serve the new screen everything is good again.

What did you already try to solve it?

For troubleshooting, I've rebooted in safe mode which of course made it work so then I started removing plugins one by one. I removed them all until I got to UI Customizer which the home screen at least worked
after disabling that. I have since fully deleted all plugins and now the control tab still locks up.

What I've noticed is that it's when viewing the camera stream the system binds. Which makes sense why UI Customizer made it look like that was the problem, because that has the camera stream on the home screen which was making it bind right after boot.

So then I thought I wonder if it's because I defined my camera in the venv as 1920x1080 20fps, and that my network might be struggling even though everything is hardwired. When I view just the stream in the browser (octoprint.local/webcam/?action=stream) it runs very smooth with just ms of delay.

So now I'm stumped, it was weird to just freeze and halt out of nowhere like that after being perfect for 48 hours. Thank you in advance for anyone who has any advice, I would love to get my build working again. Octoprint (to me) is just as much fun as the printer itself!

Let me know if there is any info you need and I will get it to you ASAP.

Systeminfo Bundle

octoprint-systeminfo-20230104194050.zip (1.9 MB)

Additional information about your setup

OctoVersion: Version 1.8.6
OctoPi: N/A
Printer: Ender 3 Pro
Firmware: Marlin bugfix 2.1.x
Browser: Firefox
OS: MacOS
Host Machine: Dell Optiplex 3020 w/ Ubuntu Server 22.04.1 LTS
16GB DDR3, 2.9 Ghz 4th Gen i5, 256GB SSD

Forgot to mention I've also cleared and disabled Printer Notifications because another user on this forum had issues there and other replied saying it helped them too. Unfortunately, not the case for me.

What streaming software are you using for the camera? Have you tried lower FPS/resolutions just to test and see if it helps?

Hey Charlie, so I actually narrowed it down a bit. I was checking system resources on my host machine, to make sure it wasn't thermal throttling from a runaway process or anything like that. When I went to remove the cover of the host, I hear the fans of my laptop screaming. I checked the resource monitor there and Firefox had my 11th gen i9 pinned to 99 percent utilization. I never really noticed because MacOS will prioritize other cores to keep one application from making the rest of the system unusable. I've since been using Octoprint in Safari, without a hitch, but knock on wood. Thanks for being willing to help out.