Control tab locks up in firefox

What is the problem?

This started 2 months ago. I used to be able to open the full interface on octoprint with firefox. Now, when I click on the control tab it locks it up and if I change tabs on firefox and come back to octoprint it just shows me the loading wheel for firefox. I am unsure of what has changed.

What did you already try to solve it?

Starting an inprivate session seems to fix the problem. Removing all extensions/plugins does not. I have no problems in Chrome or in Konqueror. I have uninstalled firefox and reinstalled it with the no change. Ocotprint loads fine on the other 2 gui browsers I have loaded on this machine, so I know that it has to be a mozilla problem.

Have you tried running in safe mode?

No need to run in safe mode as it works properly on other browsers.
Update: Same issue exists in safe mode

Did running in safe mode solve the problem?

Not required to test in safe mode
Update: No

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

browser.user_agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/534.34 (KHTML, like Gecko) konqueror/20.12.3 Safari/534.34
connectivity.connection_ok: True
connectivity.enabled: True True
connectivity.resolution_ok: True
env.hardware.cores: 4
env.hardware.freq: 1400.0
env.hardware.ram: 917016576
env.os.bits: 32 linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 3 Model B Plus Rev 1.3
env.plugins.pi_support.octopi_version: 0.17.0
env.plugins.pi_support.throttle_state: 0x80000
env.python.pip: 21.3.1
env.python.version: 3.7.3
env.python.virtualenv: True
octoprint.safe_mode: False
octoprint.version: 1.7.2
systeminfo.generator: zipapi

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint 1.7.2
browser is firefox 94.0 (64-bit)
OS Pop!_OS 21.04

A plugin could have a problem just with Firefox, you never know which is why a safe mode test is always worthwhile.

One would expect it to be some sort of conflict with an extension, as you tested successfully with an inprivate tab. Surprised that disabling all extensions in regular mode didn't fix it.

Do you think it's worth trying Firefox on another device, so it could be like a fresh install? Then reconfiguring everything as you have it on the problematic PC might help.

On the control tab, the most likely problem is the webcam stream. Does the issue still happen with webcam support disabled in the settings?

when i disable the webcam, it works on a regular tab. it is puzzling that it works with inprivate just fine but not in a regular tab with everything disabled. has to be something with the steam, but no idea what.
works on a fresh install on my windows pc. but my daily driver is my pop!os laptop. it's just annoying.

even though I had used firefox to clear all history (pages, cookies, etc), it seems it didn't clear everything. I just had to manually delete my profile and let firefox rebuild it. It seems to have fixed it.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.