Could I have flashed my BIOS?

What is the problem?

While trying to set the octopi up I was trying to connect to the router through its address and then every thing went south. I think I was connected to the router but all of a sudden everything went wrong I couldn't do anything. The keyboard quit working and so did the mouse. The text that was on the monitor disapeared I dissconnected the pi from my system and tried to reboot. It started a boot loop. It would not start windows. and would not allow the keyboard to work to get me into the bios. I shut it down.

What did you already try to solve it?

I took the hard drive out and checked it with another machine and I can access it with no problem. I figured well I just need to run the disk and start a repair of the OS. I put everything back together and made double sure everything was right. Booted: NO VIDEO. None. Everything seems to be powered up. The fans are all spinning, the mouse is energized. The keyboard is dead. I shut it down. I removed my Video card and hooked the monitor to the system video vga port. Booted: NO VIDEO, keyboard still dead. I disconnected my hard drive and connected a new one. Booted: NO VIDEO, keyboard still dead. I shut it down. Here I am.

Have you tried running in safe mode?

Keyboard will not function

Did running in safe mode solve the problem?


Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

WRITE HERE Motherboard is: INTEL DQ670W , CORE i5 quad @ 3.2ghz, 8gb DDR3, Win7 home premium, As far as Octopi Octoprint latest in October 2020. Been depressed, just getting the courage to attempt the repair. Video card Radeon SAPHIRE Dual X 7970. What did I do?

Pretty sure you didn't do anything to your bios.
But I got an other theory:

How did you connect the pi to your system and which Pi is it?

PI ZERO connected thru usb. Router is VIA SAT

Well my theory was that a Pi 4 might have drawn too much power from your usb and killed your usb chipset.
But that shouldn't happen with a Zero - unless you had your printer connected to it and the printer wasn't turned on so it was powered by the Pi.
But even then it should pretty unlikely that this killed your usb chipset.
Try your keyboard in ether usb ports - if it was in a usb 3 try a usb 2 and vice versa.

Also try to remove the cmos battery, set the clear cmos jumper and disconnect the power for a few minutes.

The video thing has me stumped. I get the feeling that FATE has her hand in this along with her sister timing. It may very well be that just as I was trying to connect the PI to my router that my motherboard failed. We will see won't we. I will try the bios thing. I will download the last known bios for this board and then pull the battery and reset the pin to clear the bios. I will follow the directions to do this anyway and see if it works. Firts I will connect a keyboard to the keyboard port instead of usb. Even though the mouse laser is powering up. I'll get back to you, Thanks for the help. I Hope something works :slight_smile:

Alright I have done some stuff and its still a bit confusing. Here goes. First I cleared out the case. I removed the Ram, the video card the drives. Then I took a brush and some air and deep cleaned the motherboard. I did not touch the processor as far as removal. Fate is already on me so I did not want to tempt her. I reinstalled the memory and made sure each was seated well. I did the same with my monster video card. I replaced the battery in the CMOS with a new one. I turned the PSU off and unplugged the unit. I held the power switch down for 60 seconds. Plugged the thing in and powered it up. We had video and we were in our bios as it had to be reset. I went through bios and set everything and hit f10. Windows booted and said it needed to run a repair. I said yes. It reported itself as restored to an earlier waypoint and all was good. I took about 15 minutes of looking around my C drive, just checking I guess, and I notice that the fans in the video card still haven't fired off. So I go into the ATI software to check that they are not off for some reason. Well I had no idea the control system for a video card could be so complicated. There must be 300 buttons and switches, graphs and numbers but there were no controls for the fans. Anyway about a half hour has passed and a flag shows that there is a new update for the drivers on this card so I said update. All went well until the update turned off the video and it never did relight. I turned the unit off and put the bios jumper back to normal and started the system. It booted the fans wound up and the video flashed NO SIGNAL and went dark. The computer shut down. Three seconds later it fires itself off the fans wind up the video flashes NO SIGNAL and promptly shuts down again to repeat. There we are. I have the old video card I removed for the upgrade I will install it and see if it will boot. I have never seen this reboot loop thing before. I know I am playing with my video cards because to me its a video issue, but I am really starting to suspect I may have a bad RAM stick. If I can get the unit up and stable again I will run diagnostics from a bootdisc and test the RAM and then the video. If anyone has a clue please share. I need my baby she controls so much of what I do. Thanks everyone.

1 Like

Finally, that is solved. My video card is going out I guess. The old card is working great and no problems with anything for hours now. So now I am back to trying to install octoprint /Octop[i and I am printing wirelessly. I hope. I was struggleing with the PI router connection thing when the card failed and made me hate everything for a while. I am happy now because things are good again but I am still dreading this router connection thing. The latest PI is flashed to a 32gb chip and installed into my PI zero and thats where I am. I am guessing there is another part, the Octoprint program that I have to install onto my computer to connect to the PI. Like a GCode sender for my mini mill. Even so I still have not figured out the router. Thanks for everything I will try to get this done myself and if I run into more problems I will post a NEW white flag. I am hoping to figure it out, I need to do this. Have a great day everyone.

1 Like

Glad to hear you were able to solve that problem :slight_smile:
May that card rest in peace :wink:

Remember that the Pi Zero is rather slow, which can affect the print quality on a 3D printer.
I guess that is not so much a problem on a mini mill - which will also operate at a slower speed I assume.

You don't need a Octoprint program on your PC to connect to the Pi. Everything is done in your webbrowser.
As soon as the Pi is connected to your home network you just enter either http://octopi.local , http://octopi or http://theipofthepi in your browsers address bar :slight_smile:

Finally!! Now I understand. The Part I think is on the computer as a program is actually a website in a browser that communicates with the PI via wifi.
I think I understand what you are getting to about the ZERO but I thought the reason for the PI is to receive the Gcode and store it to the chip on board to print from. Are you in fact saying the processor on the ZERO is the bottleneck and may not be able to transfer the code fast enough to keep up with the printer mainboard? I was kind of hoping it would at least work well enough to make this a worth while learning experience. From what I have read so far the only problems occur when any multitasking is attempted. Such as video. I will not be connecting a camera or any other device to the PI. It will be a one trick pony at this point. This project is my first attempt to do ANYTHING with a raspberry PI. The painfull part so far is still just connecting the thing to my router. I have four printers so I will probably be good at this by the time I line them all out. I just have to get it done the first time. I will invest in the 3 or 4 models for the rest which I know will allow much more real time control of the printers. This is a lot for a 67 year old JACK OF ALL TRADES. :slight_smile: . Confusing really, once I understand what is going on I generally have no problem digging in. Thanks for the help, its all still fun. Even that silly Video Card, what an adventure.

1 Like

Yep. Especially when you use several plugins and/or a webcam - but also the wifi eats a lot of cpu cycles.
If you notice stuttering while printing and blobs on your print it's probably that.
But don't let me stop you from trying it :slight_smile:

Where did you get stuck?
Configure your WiFi connection by editing octopi-wpa-supplicant.txt on the root of the flashed card when using it like a thumb drive.
It's the only partition which windows will show when you put in the SD card.
I recommend that you use Notepad ++ for editing - the windows text editors might mess the file up.
Remove the # of the lines / blocks you edit.

If it still doesn't work, take a screenshot of the octopi-wpa-supplicant.txt, blacken your ssid and password and upload it here. Maybe there is a typo or something :slight_smile:

That was fixed quite a while ago - Notepad now recognizes Linux-style EOLs.