Could not acces octoprint with hostname

What is the problem?
I can acces to my octoprint instance with the IP adress of my raspberry with 192.168.xx.xx:5000. Bit my IP isn't fixed so I would like to acces to octoprint with the hostname. For now I didn't change the hostname, it's still raspberrypi. When I try to connect with raspberrypi.local:5000, it won't work.

What did you already try to solve it?
I tried to setup avahi with this tuto [Setting up OctoPrint on a Raspberry Pi running Raspbian] at the section" Optional: Reach your printer by typing its name in address bar of your browser - Avahi/zeroconf/bonjour-based" but didn't worked.

I also tried [http://elinux.org/RPi_Advanced_Setup#Setting_up_for_remote_access_.2F_headless_operation] section "The flexible way: set up avahi / zeroconf"(

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, ...)
I installed Octoprint with this tuto : Setting up OctoPrint on a Raspberry Pi running Raspbian

Simplest way is to add a hosts file entry for the Octoprint server. If you are running your own DNS, you could also add it there....

Try this one and see if it helps.

1 Like

What type of computer are you trying to use to access your Pi? By default, Windows does not include Ahavi / Zeroconf / Bonjour.

1 Like

I tried with a windows PC, a Linux Virtual Machine on my PC and also a MAC but it works on any of those

The weird thing is that I first installed octopi and it worked, I could access with octopi.local.
But now I want to build from the sources of octoprint so I installed raspbian lite and octoprint directly from github.

Since it worked with octopi, I don't think it's a probelm from the computer I use to access mi Pi

Have you tried just http://raspberrypi:5000 ?
That's what I use. (well other hostname but still without .local)

1 Like