Cr-10 axis issues with octoprint


#1

What is the problem?
My axis is off on x/y/z for my cr-10 after installing my octoprint with rpi3.
What did you already try to solve it?
I removed the rpi3 completely. Before removing, tried changing the axis to be inverted, no go. Also tried removing plug-ins. Seems like the rpi stored code onto my cr-10 because my axis are all jacked up now without octoprint or rpi3 installed or being used at all. I am using cura as a slicer.
Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...) I don't have any of this information.


#2

What does "axis issues" mean?


#3

When is push auto home, my z axis goes up, my y axis comes forward only, and my x moves to the right place. It is about 2inches high when I go to print, the lcd reads it being centered x=0, y=0, z=0. But it is clearly not at those coordinates in the actual printer. Almost like the printer thinks it is in a different location than it is. I can move them manually by hand and by the control box, but not like I did before Octoprint. I can’t make the bed go back farther than where it “homes out” and the first print from Octoprint printed at the far back of the print bed though it was sliced to print in the center.


#4

In OctoPrint's settings, there is a section for the 'printer profile'. Your origin is probably set wrong. You may have to invert your Z axis too.