CR-10S not displaying percentage completed

What is the problem?
Printing to my CR-10S via Octoprint has a slight issue with the LCD panel display - the CR-10S is nicely displaying "elapsed time", but it does not show the "Percentage completed" either in text form OR the nice bar that moves along as the print completes.

In comparison, my Prusa (running the Prusa variant of Octoprint) does actually show the % completed.

My question is: Is this a setting that can be updated? Or is this just how it works for the CR-10S?

What did you already try to solve it?
Looking for advice on what steps to take.

Here are the logs even though there's nothing really "wrong" with the setup. Could just be a config I'm missing. Also have a look at the screen shot below.

2020-05-18 07:14:07,149 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2020-05-18 07:15:06,309 - octoprint.plugins.tracking - INFO - Sent tracking event ping, payload: {'octoprint_uptime': 7260}

I have this disabled to reduce any performance hit, can enable it if required.

Additional information:

  • OctoPrint 1.4.0
  • OctoPi 0.17.0
  • Running on a Pi Zero W
  • Creality CR-10S running Marlin TH3D U1.R2.B2 (updated from stock)

Screen shot:

As per below, there is no "% completed" bar or text when printing from Octoprint:

There's a plugin for that: M73 Progress

When printing via USB, the printer has no idea of how far in the gcode file it is because it is getting fed the file one line at a time. The plugin adds specific gcode commands while printing to tell the printer how far along the file has progressed.

You are a legend - that did it. Thank you!

That's interesting. My PRUSA running Octoprint does not show the display percentage completed. Just shows USB -------

Use the Prusa version of OctoPrint & it'll have those plugins enabled by default

Instead of a recommended new install, you just can install this:

or this:

I was watching the terminal with an Ender3 the other day, at the start of a print, Octoprint sent an M73 P0 to the standard Marlin 2.0.5 build and Marlin responded, 'unknown command' - I suspect, but haven't checked that enabling M73 has to be done in the Configuration.h before building Marlin.

I see.
The both plugins use M117 - that may work