CR 10S Pro V2 'serial' in section 'mcu' must be specified

EDIT: I started over with a fresh install of Octoprint without Klipper. Still having issues but made another post. I don't see how to delete this post.

Initial setup won't print a working g-code file from Cura. Error: Your printer's firmware reported an error. Due to that the ongoing print job will be cancelled. Reported error: Option 'serial' in section 'mcu' must be specified

WRITE HERE

What did you already try to solve it?

I looked for a place to specify the serial and looked on the forum for the correct profile for my printer

Have you tried running in safe mode?

No, I don't know how to run in safe mode

Did running in safe mode solve the problem?

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

WRITE HERE

Additional information about your setup

OctoPrint version Version 0.18.0, running on Raspberry Pi 4 Model B Rev 1.4, * OctoKlipper: AGPLv3 OctoPi version, printer Creality CR 10S V2, Creality firmware, Brave browser, Firefox browser, Windows 10
octoprint-systeminfo-20221211123215.zip (208.9 KB)
operating system, ... as much data as possible

WRITE HERE

Hint: blue words a links :wink:

You are running Klipper.

Please consult the Klipper forum:

If you didn't intend to install Klipper, which you have done, then you've installed the wrong OS image - choose just OctoPi rather than OctoKlipper. If you did want to install Klipper then don't forget that there's a lot more configuration and installation that has to be done to build the firmware for your printer first, which you can find on the Klipper website.

Thanks, I reflashed with just Octopi. Didn't know that Klipper would interfere with Octopi. Still not quite working but I will do some reading before posting again

1 Like