CR10-S Pro and Octoprint

Problem:
Octoprint (OctoPi) is able to connect to Printer (Creality CR-10 S Pro). When I manually on the printer heat up level bed for example I can see temperature rising via webgui of Octoprint -> so far OK.
Now, uploading a .gcode file is still fine and works, but as soon I want to start print, the Printer is not reacting at all. Webgui is not showing visible error.
I was looking for different FW version like from tiny-machines or from Github alternativley. Please note I have right now default FW from Creality on board. I have not tried so far any FW update
OctoPrint version: 1.3.12
Creality FW version: CR-10SPRO 1.70.1
OctoPi Version: 0.17.0
Browser: Firefox 71.0
OS: Windows 10 prof.

octoprint.log.zip (5.0 KB)

You might try homing the X/Y/Z axes first.

Many Thx OutsourcedGuru for your feedback - will try it tomorrow as soon my current print is finished. Will share afterwards

I've tried to home x/y/z - but it is not working. So, printer is not reacting when I want to steer him via Octoprint webgui. General question: Do I need to flash original (Creality) FW first? or is it in principle not an issue to use out of the box FW.

You should be able to turn the printer and the Pi on, connect the printer using the OctoPrint's Connection side panel widget, visit the Terminal screen and then enter:

G28 X Y Z        # The printer should move to whatever it thinks is the HOME position
G90              # Put the axes in absolute mode
G0 X10 Y10 F1600 # The hotend should move diagonally (10mm by 10mm)

Each response from the firmware should be something like ok rather than an error. The first and third commands I've given usually result in movement, normally. (It's possible that the printer is already homed, though.)

If the first command doesn't home and the third command doesn't move at all then something is wrong with the hardware, the firmware, the serial cable, the power to the printer... (Obviously, the printer board itself needs to be separately powered.)

Many Thx OutsourcedGuru - will give it a trial today - let u know afterwards

Hi OutsourcedGuru,

many thx again for helping. It is working now. The commands 1 and 3 were successful. G90 was my printer not responding. However, after these commands I started a small print and now my printer was starting as it should. The only difference this time, I have had no SD card in the slot - not sure if this was the reason for. However willl carefully monitor this during my next prints.

thx again

1 Like

The printer board's SD adapter probably only supports the 8.3 FAT-style filenames and in some cases, the "report file list" command seems to cause problems. So yes, in some cases then removing the SD card is the fix.

But also, when you start your printer then the firmware doesn't know what the HOME position is and may likely just refuse any movement commands until you've homed and set a movement mode.