CR10sPro V2 Warped bed? Bed Visualiser

What is the problem?

Having a bit of confusion with the bed visualiser readings on my CR10s Pro V2 with a glass bed (With original CR10s Pro V2 distance sensor). At eye level and with a level the bed seems relatively flat however according to the bed visualiser there seems to be a significant jump towards the front of my bed. I have manually levelled my print bed using a .10 shim and all is spot on from that point however bed visualiser says otherwise. Previous bed was the original CR10s Pro V2 bed and only just replaced to glass this week. Both recorded the jump. Where should I start, the bed or the sensor?
image

What did you already try to solve it?

Replaced heat bed to glass heat bed. Same issue

Have you tried running in safe mode?

No Change

Did running in safe mode solve the problem?

No

Additional information about your setup

CR10s Pro V2
Glass Heat bed
OEM Distance Sensor (Blue tip not the Bl Touch)
My Mini Factory Firmware
Octoprint firmware 1.8.2

Could be a crooked gantry.

Try to measure the distance between the left and right end of the gantry and the top of the frame.
(I guess it makes no sense to measure the distance to the bottom of the frame since there is a box underneath the bed)

Update - Resolved
Thought Id post my resolution here so if anyone else gets this in future it may fix their issues.
Reflashing/updating my Tiny Machine firmware/marlin firmware has fixed my issue. Bed is scanning as level once again!

1 Like