Creality 2X temperature plug in not working

What is the problem?

Creality 2X temperature plug in not working

I have an Ender 5 which has been upgraded with a 4.2.7 motherboard Creality 3D Upgrade Silent Mainboard, V4.2.7(V 1.1.5)Mainboard with TMC 2225 Drivers Marlin 2.0.1 (But The Ender 5 LCD displays Marlin 1.0.1 2020-04-25)

What did you already try to solve it?

Upgraded to 1.5.3 and added the Creality 2X temperature plug in (No change)
Downgraded to 1.3.6 and tried with and without the plugin still not working

Note it did work before I Upgraded the motherboard to V4.2.7. I can only assume that the temperature plugin does not work for all printer/motherboard configurations

Any suggestions on how to get this working

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Complete Logs

What log would be helpful in this case?

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible
Octoprint 1.3.6 running on Raspberry Pi 3B+
octopi_version: 0.17.0
Ender 5 see above
Browser Chrome on Mac

Additional information
Send: M115

Terminal output
Recv: TT::24.3724.37 //0.000.00 BB::24.3724.37 //0.000.00 @@::00 BB@@::00

Hello @sjgcornish!

The terminal output isn't changed with this fix.
In the terminal always the raw data from the serial input is shown.
The fix if for the correct display in the temperature graph.

I'm going to have to make a contribution somewhere that says this in big bold letters, we get far too many questions exactly the same as this.

1 Like

Ok thank you for your input. Further investigation looks as if the tool and bed temperatures only update while it is printing. As soon as printing stops then the reported temperatures freeze so you cannot track the temperatures as they cool. Is this true ?

Honestly, I'm not familiar with this plugin, because I'm not in need for it.
Maybe someone who uses it here in the forum can explain.

Please upload an OctoPrint log, so we can check there are no problems. Maybe also enable and upload a serial log too, so we can check the temperature reporting.

Ok I will get them over to you tomorrow.

Please find attached the logs from the last session

(Attachment serial.log.2021-01-24_20-23-09 is missing)

octoprint (1).log (9.7 KB)

Please find attached a file that I trust will be acceptable, I also went back to 1.5.3 (via 1.3.9) but still the same problem hence the update octoprint log.
Thank you for you attention

serial.log (4.84 KB)

octoprint (4).log (294 KB)

I think you might have the wrong plugin - you want the 2x temperature reporting fix one:

The other one you have installed is for the other Creality temperature problem. Try the above. Yes, it's very annoying that they keep having different problems.

It is working now thank you amd my apology for taking up your time. I guess I just saw the Creality Temperature plugin in the plug in manager and assumed that this was the right one since the 2X one is not available through the plugin manager (i.e. just renamed)


1 Like