Creality-2x-temperature-reporting-fix not working

I have the Creality-2x-temperature-reporting-fix (0.0.4) plugin installed and enabled. but when I suppress temperature messages I still get this:

What did you already try to solve it?

Tried enabling and disabling this plugin and the other Creality temperature plugin to see if it would make any difference but it didn't.
Googled but didn't find a solution that seemed to fit.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle (74.6 KB)

Hello @MartinMortensen !

As for the logs, you have installed both Creality temperature fix plugins.
You should use the one that is proper for your printer.

You left that info about your setup out.

This is the intended behaviour. It only rewrites the lines internally for parsing by OctoPrint, the actual communication from the printer can't be changed by the plugin, which is what you are watching in the terminal. You will be able to tell it is working if the temperature graph works properly now.

1 Like

Well ok, but that's disappointing. It makes the terminal a pain to use.

You should complain to Creality (they won't listen) or just flash your own firmware then to properly fix the problem.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.