Creality Cr-10 connection problem!

Just installed Octopi to control my CR-10.
Unfortunately can't I connect...
Getting the following error:
Unexpected error while connecting to serial port: /dev/ttyUSB0 Timeout: 'Timeout' @ comm.py:_openSerial:2611 (hook GPX)
Anyone got a clue why?

I get a warning of undervoltage though I run a 3A power supply?

//Carl

Bra

If you're getting an undervoltage warning with an actual 5V @ 3A power adapter then I'd be surprised.

  • Run it in Safe Mode with the printer disconnected and see if you get the undervoltage indication again.
  • Unplug anything extra that's plugged into the Pi (thumbdrive, printer, webcam, hat, whatever) and see if the undervoltage condition goes away.
  • Plug the power adapter into a UPS to make sure that you're getting the correct voltage from the wall outlet in the first place.

I started to get under voltage and am using 40W adjustable AD/DC converter set to 5.2V output. It is most definitely an issue with my USB cable since the PSU can easily output several times the required power, so you might want to check your cable too. You can order a beefy power only cable quite cheaply. Here is one I found on monoprice.com that has 24AWG power wires and is very short. It should be able to carry way more current than you need for the RPI.. Some cables have as low as 30AWG power cables, like this cable I found also on monoprice, which would NOT be suitable IMHO at any length.

Edit: Linked to wrong PSU, changed the link and the specs.

Honestly, power over USB is limited by the technical specifications. So the gauge of wiring in USB cables, connectors and plugs matches that specification (to barely meet it). Type-A and Type-B connectors are supposed to be 5V @ 2A maximum. The 28-gauge wire typically found in USB cables is good enough to carry 500mA at 5V. You're looking for a cable which uses at least 24-gauge for the pair of power wires. (This is why I'm always reminding that a shorter cable is better.)

USB Power Delivery

Note that you can solder some larger-gauge wires to your Pi's motherboard if you want to bypass these limitations.

Acceptable loss calculator says 5V @ 3A @ 1/3 meter @ 1% loss = 18 AWG (1% loss of 5V input = 4.95V output which is well above the 4.64V threshold)

Some 1-foot USB cables then:
21 AWG (2% loss of 5V input = 4.9V)
23 AWG (3% loss of 5V input = 4.85V)
24 AWG (4% loss of 5V input = 4.8V)

It's possible that their calculator is buggy, though.

I wonder what the loss would be for a 30AWG wire, as can be found in many USB cables. That calculator suggests that even the thickest cable I found had a 5% loss at 1 foot!? For 1 meter they suggest 19AWG.

It would have been much easier if the PI ran on 12V, but alas.

The power requirements changed slowly over time and they must have been in denial about doing anything drastic to change the power delivery.

Product Recommended PSU current capacity Maximum total USB peripheral current draw Typical bare-board active current consumption
Raspberry Pi Model A 700mA 500mA 200mA
Raspberry Pi Model B 1.2A 500mA 500mA
Raspberry Pi Model A+ 700mA 500mA 180mA
Raspberry Pi Model B+ 1.8A 600mA/1.2A (switchable) 330mA
Raspberry Pi 2 Model B 1.8A 600mA/1.2A (switchable) 350mA
Raspberry Pi 3 Model B 2.5A 1.2A 400mA
Raspberry Pi 3 Model A+ 2.5A Limited by PSU, board, and connector ratings only. 350mA
Raspberry Pi 3 Model B+ 2.5A 1.2A 500mA
Raspberry Pi 4 Model B 3.0A 1.2A 600mA
Raspberry Pi Zero W/WH 1.2A Limited by PSU, board, and connector ratings only. 150mA
Raspberry Pi Zero 1.2A Limited by PSU, board, and connector ratings only 100mA