Creality CR-10 Max - Connected but not printing

What is the problem?

I have connected OctoPrint to my Creality CR10 Max. I was able to send a G-code command to understand the firmware settings. Here it is.

Send: M503
Recv: echo: G21 ; Units in mm
Recv: echo: M149 C ; Units in Celsius
Recv: echo:Filament settings: Disabled
Recv: echo: M200 D1.75
Recv: echo: M200 D0
Recv: echo:Steps per unit:
Recv: echo: M92 X80.00 Y80.00 Z400.00 E140.00
Recv: echo:Maximum feedrates (units/s):
Recv: echo: M203 X500.00 Y500.00 Z10.00 E50.00
Recv: echo:Maximum Acceleration (units/s2):
Recv: echo: M201 X500 Y500 Z100 E5000
Recv: echo:Acceleration (units/s2): P<print_accel> R<retract_accel> T<travel_accel>
Recv: echo: M204 P500.00 R1000.00 T500.00
Recv: echo:Advanced: S<min_feedrate> T<min_travel_feedrate> B<min_segment_time_ms> X<max_xy_jerk> Z<max_z_jerk> E<max_e_jerk>
Recv: echo: M205 S0.00 T0.00 B20000 X8.00 Y8.00 Z0.40 E5.00
Recv: echo:Home offset:
Recv: echo: M206 X0.00 Y0.00 Z0.00
Recv: echo:Auto Bed Leveling:
Recv: echo: M420 S1 Z0.00
Recv: echo:PID settings:
Recv: echo: M301 P30.86 I3.10 D75.84
Recv: echo:Z-Probe Offset (mm):
Recv: echo: M851 Z-1.70
Recv: ok

I also get lots of connection status messages in the log.

I uploaded a gcode file to print. That seemed to work fine. But when I tried to print, it sat for a while and then both OctoPrint and the printer itself reported an error that it did not heat ("Error: Heating failed, system stopped! Heater_ID: bed - Printer halted. kill() called!").

What did you already try to solve it?

I reloaded the file and tried again.

Logs (octoprint.log, serial.log or output on terminal tab, browser error console ...)

Here is a bit more from the log.

Changing monitoring state from "Operational" to "Starting"
Send: N0 M110 N0125
Recv: ok
Changing monitoring state from "Starting" to "Printing"
Send: N1 M140 S50
Recv: ok
Send: N2 M10537
Recv: ok == T:24.14 /0.00 == B:24.30 /50.00 @:0 B@:0
Send: N3 M190 S50
Recv: == T:24.14 /0.00 == B:24.30 /50.00 @:0 B@:0 W:?
Recv: == T:24.02 /0.00 == B:24.37 /50.00 @:0 B@:0
Recv: == T:24.22 /0.00 == B:24.45 /50.00 @:0 B@:127 W:?
Recv: echo:busy: processing
Printer seems to support the busy protocol, will adjust timeouts and set busy interval accordingly


Recv: Error:Heating failed, system stopped! Heater_ID: bed
Recv: Error:Printer halted. kill() called!
Changing monitoring state from "Printing" to "Error: Heating failed, system stopped! Heater_ID: bed - Printer halted. kill() called!"
Changing monitoring state from "Error: Heating failed, system stopped! Heater_ID: bed - Printer halted. kill() called!" to "Offline (Error: Heating failed, system stopped! Heater_ID: bed - Printer halted. kill() called!)"
Connection closed, closing down monitor

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ...)

OctoPrint 1.3.11
OctoPi Version 0.16.0, running on Raspberry Pi 3 Model B Rev 1.2
CR-10 Max Firmware Ver 1.70.0 BL

Deas the bed heat up if you're just using the display menu without octoprint connected?
I guess there is something wrong with the bed heater. Maybe the cables aren't connected proberly.

1 Like

Did not know you are a Scotsman :joy:

1 Like

Yeah early in the morning I'm a grumpy Scotsman :smiley:

1 Like

The printer works perfectly when controlled directly.

Well then I think that's a case for detective @foosel :wink:

1 Like

I fear I can't do anything here - it's the firmware that's reporting a heating error, that's completely outside of the control of OctoPrint.

I have also encountered a similar situation. I have CR-10S and Ender-3S .
There are two situations that can cause my printer CR-10S heating error...
fiirst, Only the usb line is connected, no power is turned on
second, loose power cord or poor power cord contact.
So, I think The cause of the heating failure is the power cord.

Thanks for the suggestions.

I have spent more time digging into this. I have sent the exact same commands that are executed locally - from the gcode file. I sent the heat commands.

M140 S50
M190 S50

It changes the printer console to show 50 degrees but it never heats.

When I unplug the raspberry pi and manually set the temperature to 50 degrees it heats up fine. So there is no problem with the bed heating up.

I will connect Creality to see if there is a newer version of the firmware...

Any other ideas??


You could use a own marlin firmware
I also had some issues with the creality firmware and my own marlin with slightly modded example config solved them

I decided to return the printer.

I have spent too much time this far - roughly 25 prints. NONE of them have been good prints in terms of matching the design. I have measured and tried to calibrate with Cura. I installed my raspberry pi with OctoPi so that I could use OctoPrint. It was my hope that I could change some firmware settings, print and remotely monitor. But that failed - some kind of firmware problem. I looked at installing a different version of firmware, but heard about lots of problems doing that (including a convoluted way to get to actually update the firmware - remove screws, small hands...).

I think a $1k+ machine should be better than that.

Now the question is - what to buy that will start out printing to spec, and that I can upgrade to make it even better... Any suggestions??

I need a printer that is at least 300x300x?

Don't buy a Robo 3D. :laugh:

1 Like